Percona XTRDB - Cluster node 3 weird client issue

Hi all,
I have configured a Percona cluster on the following:
Ubuntu 22.04 - 3 Servers in the Cluster
Percona XTRADB - 8

I do not know if this is a Percona issue or if this could be a freeradius issue.

I am using the freeradius and Percona Cluster for Centralised admin currently but will be expanding this to Customers too in the future. So, with that in mind I have been testing to network equipment and also the cluster itself.
So, I configured users and NAS in freeradius and this is inserted into the cluster correctl. I add to one and the master/master/master relationship means it replicates immediately to the other 2 servers. Awesome so far.
Then I configure the Network device to talk to each server in turn.
Now for the utlimate test. Shut down a Percona Server at a time.
When I shut down server 1, the user can still logon to the device via server 2 (the next one it tries in its list).
When I shut down cluster 1 and 2, the user cannot login with only cluster server 3 running.
When I run freeradius in debug mode (-X) (I did this to see if the auth request actually reaches the server and it does) it comes up stating “Unrecignised client (NAS)”. However, upon going into mysql on the server, the DB shows the same information on the other two. And it works on the other two, just not this one. This is really strange as the info is exactly the same across the 3 server cluster.

Anyone got any ideas why the NAS device, which is the same on all three servers, is recognised by the first two in the cluster but not the third?

If any readouts are required, please let me know.

This points to the issue being within Freeradius (FR). After you shut down node1 and node2, I would go to node3 and turn on general_log. This will log every SQL received. Examine this log for FR queries and figure out which one is failing, causing FR to report incorrectly.

I would setup something like HAProxy or ProxySQL to handle load-balancing/HA of your cluster, rather than using a feature in the “network device”. You have much more control over the architecture and can make changes without touching the network device.

Hi Matthew,
Yes, it certainly is something to do with RADIUS. The weird thing is that everything is the same on Server 3 as the other 2 but if I run freeradius in debug mode and watch when the auth packet is received, the error message is “Unknown device”. Very strange.