Percona Xtradb Cluster Crash


I am using ubuntu 20.04 and pxc db 1:8.0.30-22-1.focal.

Today my PXC DB cluster crashed with below errors in error.log.

2023-03-15T02:02:17.406355+05:00 3964911 [Note] [MY-000000] [WSREP] MDL conflict db= table= ticket=1 solved by abort
2023-03-15T02:02:17.406453+05:00 3964910 [Note] [MY-000000] [WSREP] MDL conflict db= table= ticket=10 solved by abort
2023-03-15T02:02:27.585516+05:00 3964923 [Note] [MY-000000] [WSREP] MDL conflict db= table= ticket=1 solved by abort
2023-03-15T02:02:27.585669+05:00 3964920 [Note] [MY-000000] [WSREP] MDL conflict db= table= ticket=10 solved by abort
2023-03-15T02:03:08.346053+05:00 3964974 [Note] [MY-000000] [WSREP] MDL conflict db= table= ticket=10 solved by abort
2023-03-15T02:03:08.492057+05:00 3964917 [Note] [MY-000000] [WSREP] Initiating SST cancellation
21:03:08 UTC - mysqld got signal 11 ;
Most likely, you have hit a bug, but this error can also be caused by malfunctioning hardware.

Build ID: 071623e1b6d8c9257cae7dd3627d70470ca759ca
Server Version: 8.0.30-22.1 Percona XtraDB Cluster (GPL), Release rel22, Revision aff6a8b, WSREP version 26.4.3, wsrep_26.4.3

Thread pointer: 0x7f3fe020a420
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7f3fc5669d10 thread_stack 0x100000
/usr/sbin/mysqld(my_print_stacktrace(unsigned char const*, unsigned long)+0x41) [0x556dcba16871]
/usr/sbin/mysqld(print_fatal_signal(int)+0x323) [0x556dcaa26093]
/usr/sbin/mysqld(handle_fatal_signal+0xd0) [0x556dcaa26170]
/lib/x86_64-linux-gnu/ [0x7f421fb2e420]
/usr/sbin/mysqld(end_of_list+0) [0x556dcd92f320]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (7f3fe0108cd0): SELECT AS container_consumer_metadata_id, container_consumer_metadata.created_at AS container_consumer_metadata_created_at, container_consumer_metadata.updated_at AS container_consumer_metadata_updated_at, container_consumer_metadata.deleted_at AS container_consumer_metadata_deleted_at, container_consumer_metadata.deleted AS container_consumer_metadata_deleted, container_consumer_metadata.`status` AS container_consumer_metadata_status, container_consumer_metadata.container_id AS container_consumer_metadata_container_id, container_consumer_metadata.project_id AS container_consumer_metadata_project_id, AS container_consumer_metadata_name, container_consumer_metadata.`URL` AS `container_consumer_metadata_URL`, container_consumer_metadata.data_hash AS container_consumer_metadata_data_hash  FROM container_consumer_metadata  WHERE '177c62bc-2503-4ca5-8ba6-8bcb8f4d87d1' = container_consumer_metadata.container_id
Connection ID (thread ID): 3964917

You may download the Percona XtraDB Cluster operations manual by visiting You may find information
in the manual which will help you identify the cause of the crash.

Could you advise if the issue has been fixed in release here

Or is it separate one ?


Hi Ahmad,

The issue reported is fixed. Were you upgrading from a previous version?




I have just upgraded my nodes from 8.0.30-22-1.focal to 8.0.31-23-1.focal.

Till now didn’t seen the MDL conflict errors in error logs. I am monitoring it.

Ammad Ali


The upgrade should fix that issue.

Thank you!