Percona-server-server-5.7.39-42 Upgrade Failure on Debian 10 and Ubuntu 20.04

Yesterday I ran a normal “apt update && apt ugprade” like I always do and there was an upgrade available for the 3 following packages :

The following packages will be upgraded:
   percona-server-client-5.7 percona-server-common-5.7 percona-server-server-5.7

This was an upgrade from 5.7.38-41-1 to 5.7.39-42-1.

Then the upgrade of “percona-server-server-5.7” failed and I’m now totally unable to start mysql anymore…

Here are the errors :

Job for mysql.service failed because the control process exited with error code.
See "systemctl status mysql.service" and "journalctl -xe" for details.
invoke-rc.d: initscript mysql, action "start" failed.
● mysql.service - Percona Server
   Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/mysql.service.d
   Active: activating (auto-restart) (Result: exit-code) since Wed 2022-08-17 09:38:52 CEST; 8ms ago
  Process: 3381 ExecStartPre=/usr/share/mysql/mysql-systemd-start pre (code=exited, status=0/SUCCESS)
  Process: 3426 ExecStartPre=/usr/bin/ps_mysqld_helper (code=exited, status=0/SUCCESS)
  Process: 3432 ExecStart=/usr/sbin/mysqld --daemonize --pid-file=/var/run/mysqld/ $MYSQLD_OPTS (code=exited, status=1/FAILURE)

Aug 17 09:38:52 ubuntu-srv systemd[1]: Failed to start Percona Server.
dpkg: error processing package percona-server-server-5.7 (--configure):
 installed percona-server-server-5.7 package post-installation script subprocess returned error exit status 1
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for systemd (241-7~deb10u8) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

This was on an Ubuntu 20.04 server, but then I also tried on a Debian 10 snapshot server running the same things and I got the same error.

I was able to restore a snapshot of the Ubuntu server to keep my prod running and I excluded the Percona updates with “apt-mark hold” but I don’t understand why Percona failed, I usually don’t have any problem with this kind of minor updates.

Any idea how could I fix it ? Thank you.

1 Like


Can you please check the error log and provide us the error message that’s causing the failure?



Here is what I get in /var/log/mysql/mysql_error.log when I try to start mysql with “service mysql start” :

2022-08-17T08:27:15.908732Z 0 [Warning] The syntax '--log_warnings/-W' is deprecated and will be removed in a future release. Please use '--log_error_verbosity' instead.
2022-08-17T08:27:15.908877Z 0 [Warning] The syntax '--log_warnings/-W' is deprecated and will be removed in a future release. Please use '--log_error_verbosity' instead.
2022-08-17T08:27:15.908899Z 0 [Warning] options --log-slow-admin-statements, --log-queries-not-using-indexes and --log-slow-slave-statements have no effect if --slow-query-log is not set
2022-08-17T08:27:15.908907Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.
2022-08-17T08:27:15.909750Z 0 [Note] /usr/sbin/mysqld (mysqld 5.7.39-42) starting as process 29196 ...
2022-08-17T08:27:15.991600Z 0 [Warning] InnoDB: Using innodb_support_xa is deprecated and the parameter may be removed in future releases. Only innodb_support_xa=ON is allowed.
2022-08-17T08:27:15.991688Z 0 [Warning] InnoDB: Setting innodb_checksums to OFF is DEPRECATED. This option may be removed in future releases. You should set innodb_checksum_algorithm=NONE instead.
2022-08-17T08:27:15.991742Z 0 [Note] InnoDB: PUNCH HOLE support available
2022-08-17T08:27:15.991750Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2022-08-17T08:27:15.991754Z 0 [Note] InnoDB: Uses event mutexes
2022-08-17T08:27:15.991757Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2022-08-17T08:27:15.991764Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.12
2022-08-17T08:27:15.991767Z 0 [Note] InnoDB: Using Linux native AIO
2022-08-17T08:27:15.992254Z 0 [Note] InnoDB: Number of pools: 1
2022-08-17T08:27:15.992318Z 0 [Note] InnoDB: Using CPU crc32 instructions
2022-08-17T08:27:15.993563Z 0 [Note] InnoDB: Initializing buffer pool, total size = 4G, instances = 4, chunk size = 128M
2022-08-17T08:27:16.053090Z 0 [Note] InnoDB: Completed initialization of buffer pool
2022-08-17T08:27:16.065486Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2022-08-17T08:27:16.076807Z 0 [Note] InnoDB: Crash recovery did not find the parallel doublewrite buffer at /var/lib/mysql/xb_doublewrite
2022-08-17T08:27:16.077937Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2022-08-17T08:27:16.131754Z 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2022-08-17T08:27:16.131825Z 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2022-08-17T08:27:16.145687Z 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2022-08-17T08:27:16.146435Z 0 [Note] InnoDB: 96 redo rollback segment(s) found. 96 redo rollback segment(s) are active.
2022-08-17T08:27:16.146454Z 0 [Note] InnoDB: 32 non-redo rollback segment(s) are active.
2022-08-17T08:27:16.147029Z 0 [Note] InnoDB: Waiting for purge to start
2022-08-17T08:27:16.197236Z 0 [Note] InnoDB: Percona XtraDB ( 5.7.39-42 started; log sequence number 236174034342
2022-08-17T08:27:16.197590Z 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
2022-08-17T08:27:16.198131Z 0 [Note] Plugin 'FEDERATED' is disabled.
2022-08-17T08:27:16.198366Z 0 [Note] InnoDB: Buffer pool(s) load completed at 220817 10:27:16
2022-08-17T08:27:16.201365Z 0 [ERROR] unknown variable 'myisam_repair_threads=1'
2022-08-17T08:27:16.201403Z 0 [ERROR] Aborting

2022-08-17T08:27:16.201434Z 0 [Note] Binlog end
2022-08-17T08:27:16.201479Z 0 [Note] Shutting down plugin 'auth_socket'
2022-08-17T08:27:16.201521Z 0 [Note] Shutting down plugin 'ngram'
2022-08-17T08:27:16.201526Z 0 [Note] Shutting down plugin 'partition'
2022-08-17T08:27:16.201531Z 0 [Note] Shutting down plugin 'BLACKHOLE'
2022-08-17T08:27:16.201536Z 0 [Note] Shutting down plugin 'ARCHIVE'
2022-08-17T08:27:16.201541Z 0 [Note] Shutting down plugin 'MRG_MYISAM'
2022-08-17T08:27:16.201547Z 0 [Note] Shutting down plugin 'MyISAM'
2022-08-17T08:27:16.201566Z 0 [Note] Shutting down plugin 'INNODB_TABLESPACES_SCRUBBING'
2022-08-17T08:27:16.201574Z 0 [Note] Shutting down plugin 'INNODB_TABLESPACES_ENCRYPTION'
2022-08-17T08:27:16.201581Z 0 [Note] Shutting down plugin 'INNODB_SYS_VIRTUAL'
2022-08-17T08:27:16.201588Z 0 [Note] Shutting down plugin 'INNODB_CHANGED_PAGES'
2022-08-17T08:27:16.201595Z 0 [Note] Shutting down plugin 'INNODB_SYS_DATAFILES'
2022-08-17T08:27:16.201602Z 0 [Note] Shutting down plugin 'INNODB_SYS_TABLESPACES'
2022-08-17T08:27:16.201610Z 0 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
2022-08-17T08:27:16.201618Z 0 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
2022-08-17T08:27:16.201625Z 0 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
2022-08-17T08:27:16.201633Z 0 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
2022-08-17T08:27:16.201640Z 0 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
2022-08-17T08:27:16.201648Z 0 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
2022-08-17T08:27:16.201655Z 0 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
2022-08-17T08:27:16.201688Z 0 [Note] Shutting down plugin 'INNODB_FT_INDEX_TABLE'
2022-08-17T08:27:16.201696Z 0 [Note] Shutting down plugin 'INNODB_FT_INDEX_CACHE'
2022-08-17T08:27:16.201704Z 0 [Note] Shutting down plugin 'INNODB_FT_CONFIG'
2022-08-17T08:27:16.201711Z 0 [Note] Shutting down plugin 'INNODB_FT_BEING_DELETED'
2022-08-17T08:27:16.201718Z 0 [Note] Shutting down plugin 'INNODB_FT_DELETED'
2022-08-17T08:27:16.201726Z 0 [Note] Shutting down plugin 'INNODB_FT_DEFAULT_STOPWORD'
2022-08-17T08:27:16.201733Z 0 [Note] Shutting down plugin 'INNODB_METRICS'
2022-08-17T08:27:16.201740Z 0 [Note] Shutting down plugin 'INNODB_TEMP_TABLE_INFO'
2022-08-17T08:27:16.201747Z 0 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
2022-08-17T08:27:16.201754Z 0 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
2022-08-17T08:27:16.201761Z 0 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
2022-08-17T08:27:16.201768Z 0 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX_RESET'
2022-08-17T08:27:16.201773Z 0 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX'
2022-08-17T08:27:16.201778Z 0 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
2022-08-17T08:27:16.201782Z 0 [Note] Shutting down plugin 'INNODB_CMPMEM'
2022-08-17T08:27:16.201787Z 0 [Note] Shutting down plugin 'INNODB_CMP_RESET'
2022-08-17T08:27:16.201792Z 0 [Note] Shutting down plugin 'INNODB_CMP'
2022-08-17T08:27:16.201797Z 0 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
2022-08-17T08:27:16.201802Z 0 [Note] Shutting down plugin 'INNODB_LOCKS'
2022-08-17T08:27:16.201806Z 0 [Note] Shutting down plugin 'INNODB_TRX'
2022-08-17T08:27:16.201811Z 0 [Note] Shutting down plugin 'XTRADB_ZIP_DICT_COLS'
2022-08-17T08:27:16.201816Z 0 [Note] Shutting down plugin 'XTRADB_ZIP_DICT'
2022-08-17T08:27:16.201821Z 0 [Note] Shutting down plugin 'XTRADB_RSEG'
2022-08-17T08:27:16.201825Z 0 [Note] Shutting down plugin 'XTRADB_INTERNAL_HASH_TABLES'
2022-08-17T08:27:16.201830Z 0 [Note] Shutting down plugin 'XTRADB_READ_VIEW'
2022-08-17T08:27:16.201834Z 0 [Note] Shutting down plugin 'InnoDB'
2022-08-17T08:27:16.201936Z 0 [Note] InnoDB: FTS optimize thread exiting.
2022-08-17T08:27:16.202087Z 0 [Note] InnoDB: Starting shutdown...
2022-08-17T08:27:16.302342Z 0 [Note] InnoDB: Dumping buffer pool(s) to /var/lib/mysql/ib_buffer_pool
2022-08-17T08:27:16.302726Z 0 [Note] InnoDB: Buffer pool(s) dump completed at 220817 10:27:16
2022-08-17T08:27:17.303661Z 0 [Note] InnoDB: Waiting for page_cleaner to finish flushing of buffer pool
2022-08-17T08:27:18.737475Z 0 [Note] InnoDB: Shutdown completed; log sequence number 236174034361
2022-08-17T08:27:18.738680Z 0 [Note] InnoDB: Removed temporary tablespace data file: "ibtmp1"
2022-08-17T08:27:18.738700Z 0 [Note] Shutting down plugin 'MEMORY'
2022-08-17T08:27:18.738705Z 0 [Note] Shutting down plugin 'CSV'
2022-08-17T08:27:18.738709Z 0 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
2022-08-17T08:27:18.738756Z 0 [Note] Shutting down plugin 'sha256_password'
2022-08-17T08:27:18.738761Z 0 [Note] Shutting down plugin 'mysql_native_password'
2022-08-17T08:27:18.739398Z 0 [Note] Shutting down plugin 'binlog'
2022-08-17T08:27:18.741906Z 0 [Note] /usr/sbin/mysqld: Shutdown complete
1 Like

Ok I just found the reason… There was the following line in a custom config :

myisam_repair_threads = 1

I commented it out and mysql is now starting.

1 Like


This variable has been deprecated in 5.7.38 and removed in 5.7.39.


Ok noted, thanks a lot for your help.