Percona Server 8.0.28-19 for Zenfs Failed

Hello,
I follow “Installing and configuring Percona Server for MySQL with ZenFS guide” to install server. When I add the “loose-rocksdb-fs-uri=zenfs://dev:nvme0n1” in /etc/mysql/my.cnf, I can not enable "ps-admin --enable-rocksdb -u root -p ".

Does anybody can help me?

Installation guide :

Thanks,
Edward

Edward,

Please double-check the following:

  1. Make sure that “/dev/nvme0n1” is indeed the zoned block device installed on your system (check the “lsblk -o NAME,SIZE,ZONED” output).
  2. Identify the Linux user your instance of Percona Server will be run under (by default, it is “mysql:mysql”);
  3. Make sure this user (“mysql:mysql”) has write permissions on the zoned block device ("/dev/nvme0n1") - “ls -l /dev/nvme0n1”
  4. Make sure that the auxiliary directory ("/var/lib/mysql_zenfs_aux_nvme0n2") you created and then used in “zenfs mkfs --zbd=nvme0n1 --aux_path=/var/lib/mysql_zenfs_aux_nvme0n2 …” has write permissions for the Percona Server system user (“mysql:mysql”) - “ls -la /var/lib/mysql_zenfs_aux_nvme0n2”.
  5. Make sure “zenfs mkfs” operation succeeded - check by running “zenfs ls-uuid”
  6. Make sure there are no leftovers from your previous attempts on the ZenFS volume before you run "ps-admin --enable-rocksdb -u root -p " - check by running “zenfs list --zbd=nvme0n1 --path=/”, this should give you an empty list. If there is something, the easiest way to clean everything would be to re-run “zenfs mkfs …”.
1 Like

Hi Yura,

I have checked these steps. But I still can’t enable rocksdb. When I execute command “ps-admin --enable-rocksdb -u root -p password”, the command will be changed without any response.

Following is my installing steps.
Link: Install Percona Server and RocksDB.md - Google Docs

Ubuntu : 20.04.1
Kernel : 5.13.0-30-generic

Thanks,
Edward

1 Like

Edward,
I do not see anything wrong with the steps you described in your Google document.
Everything there is according to the instructions.
At this stage I can only advice to check the Percona Server logs while you execute “ps-admin --enable-rocksdb …”.
Moreover, checking Linux system logs and AppArmour logs in particular for new errors/warnings during this process may also give you a hing what is wrong.

1 Like

One more idea…
Regarding the kernel. You mentioned that you are using “5.13.0-30-generic” on Ubuntu Focal.
Something might have changed since then, but the last time I checked this platform (about 2-3 months ago), the latest HWE kernel was 5.11 and it did not have all the required ZBD patches.
([PATCH 0/2] allow blk-zoned ioctls without CAP_SYS_ADMIN)
And to be honest I do not know if in 5.13 the situation has changed.

1 Like

OK! Thanks you for your help. I will try to install Debian 11.1 or latest version that official website recommends.

Thanks,
Edward

1 Like