Percona - missing rows in binlog, when format is STATEMENT

I am trying to setup replication for my application. I have the binlog format set to STATEMENT and the tx_isolation set to REPEATABLE-READ. It started with data missing in a couple of tables in the slave database. When I tried to dig further, I noticed that many of the records are inserted into the table in the database but do not have entries in the binlog. The question I have is why they are missing in the binlog?

A couple of other patters I noticed is that when I have multiple rows inserted in the table in the same millisecond, I see only 1 entry in the binlog. The other pattern is that a block of inserts into the database table are missing in the binlog.

I have tried to change the binlog format to MIXED. I still see the issue.

It will be great to find out what I am missing or how to fix this issue.

Hi @“aravind.rrao”
entries missing in the Binlog: This is possible in below cases,
1) when set sql_log_bin=0 (session level)–> insert statement. In this case it will not log to the binlog.
2) binlog-ignore-db is used. (this is less likely as you have observed some inserts are working and some aren’t)