Percona 5.5.23


I’ve upgraded My Percona on 5.5.23.
The first node start without problem, but the others nodes failed due to errors :

120516 14:57:44 [Warning] WSREP: Failed to prepare for incremental state transfer: Local state UUID (00000000-0000-0000-0000-000000000000) does not match group state UUID (18df8ebb-848f-11e1-0800-34439383ee44): 1 (Operation not permitted)
at galera/src/replicator_str.cpp:prepare_for_IST():439. IST will be unavailable.
120516 14:57:44 [Note] WSREP: Node 0 (percona-node2) requested state transfer from ‘any’. Selected 1 (percona-node1)(SYNCED) as donor.
120516 14:57:44 [Note] WSREP: Shifting PRIMARY -> JOINER (TO: 1403)
120516 14:57:44 [Note] WSREP: Requesting state transfer: success, donor: 1
120516 14:57:54 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup ‘joiner’ ‘’ ‘:**’ ‘/var/lib/mysql/’ ‘/etc/mysql/my.cnf’ ‘1756’ 2>sst.err: 32 (Broken pipe)
120516 14:57:54 [ERROR] WSREP: Failed to read uuid:seqno from joiner script.
120516 14:57:54 [ERROR] WSREP: SST failed: 32 (Broken pipe)
120516 14:57:54 [ERROR] Aborting

120516 14:57:54 [Warning] WSREP: 1 (percona-node1): State transfer to 0 (percona-node2) failed: -1 (Operation not permitted)
120516 14:57:54 [ERROR] WSREP: gcs/src/gcs_group.c:gcs_group_handle_join_msg():712: Will never receive state. Need to abort.

In the sst.err file:
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
Error while getting st data from donor node

In innobackup.backup.log file :
xtrabackup: Error: Please set parameter ‘datadir’
innobackupex: fatal error: no ‘mysqld’ group in MySQL options
innobackupex: fatal error: OR no ‘datadir’ option in group ‘mysqld’ in MySQL options

Why this pb and how to resolve it

Thx a lot

azigui wrote on Wed, 16 May 2012 16:26

Have you looked at your /etc/mysql/my.cnf?

I resolve it, you must put in my.cnf file in [MYSQLD] section :

Be carrefull, you can probably obtain a start/stop failed, so you must update password for mysql user debian-syst-main.
This password is written in debian.cnf file