mysqlbinlog segfault on 5.1.61-rel113.2-log

It’s a normal situation where one want to decode the binlog to understand in case a replication failed.
normally one would do:
$ mysqlbinlog --verbose --base64-output=DECODE-ROWS >
For some reason, starting with v5.1.60 it segfault.
If i use the binary of mysqlbinlog from 5.1.59 it works.
I have tried to run it both on rhel 5.7 and rhel 6.2, both segfault.

[Percona-Server-5.1.61-rel13.2-430.Linux.x86_64/bin]# ldd mysqlbinlog => (0x00007fff59ffc000) => /lib64/ (0x0000003e21800000) => /usr/lib64/ (0x0000003631200000) => /lib64/ (0x0000003e23000000) => /lib64/ (0x0000003e23400000) => /lib64/ (0x0000003e21c00000) => /usr/lib64/ (0x0000003e22400000) => /lib64/ (0x0000003e22c00000) => /lib64/ (0x0000003e21000000)
/lib64/ (0x0000003e20c00000)

[Percona-Server-5.1.59-rel13.0-325.Linux.x86_64/bin]# ldd mysqlbinlog => (0x00007fff8e8e6000) => /lib64/ (0x0000003e21800000) => /usr/lib64/ (0x0000003631200000) => /lib64/ (0x0000003e22c00000) => /lib64/ (0x0000003e23000000) => /lib64/ (0x0000003e23400000) => /lib64/ (0x0000003e21c00000) => /usr/lib64/ (0x0000003e22400000) => /lib64/ (0x0000003e21000000)
/lib64/ (0x0000003e20c00000)

Is this specific to Percona Server’s distribution or does it happen with standard MySQL too?

I haven’t tried yet, is there a way to get the binaries as you can with percona?