Mysql not starting, no wsrep

Hello!

I’m trying to startup percona + mysql + galera on FreeBSD 13. I am using the packages from pkg.

I can start my database without any wsrep settings in my my.cnf file. As soon as I add the wsrep settings, mysql won’t start, failing on the first wsrep setting listed. E.g.

[ERROR] /usr/local/libexec/mysqld: unknown variable ‘wsrep_on=ON’

I saw another post of someone having similar issues, and their suggestion was that the libgalera_smm.so was in the wrong place on their system. Is this library where mysqld gets the wsrep settings? I tried linking this library several places on my system, but it didn’t help.

Thanks for any ideas that you have!

Cheers, Aaron

1 Like

Correct. This is the typical setting when using the package installer:

wsrep_provider = /usr/lib64/galera3/libgalera_smm.so

Find this library, wherever it is on your system (check the package metadata to see where it was installed) and use that path in your my.cnf Don’t symlink, just use the path directly.

1 Like

I did include the wsrep_provider, and even included the flag on the command line to set it. Still no soup.

After digging around more, it appears that mysql needs to be compiles with -DWITH_WSREP=ON. Otherwise, I believe, the wsrep variables and that functionality will not be available.

Here is my reference: Has anyone setup MariaDB 5.5 with Galera on FreeBSD 10? | The FreeBSD Forums

1 Like

I assumed you were using the official Percona XtraDB Cluster packages which natively includes Galera libraries. I recommend that instead of compiling from source, you use the packages we provide.

https://www.percona.com/downloads/Percona-XtraDB-Cluster-57/LATEST/

1 Like