MySQL crashes system



CentOS 3.5 (2.4.21)
MySQL 5.0.64 Enterprise Server (Commercial)

System variables:

bulk_insert_buffer_size 8388608
key_buffer_size 268435456
myisam_data_pointer_size 6
myisam_max_sort_file_size 2146435072
myisam_sort_buffer_size 67108864

We have an application which pumps in excess of 500 records/sec to MYISAM database and after 10 hrs or so, system silently crashes.After doing a power cycle, it is found the database has crashed and tables are corrupted.

mysql> select * from xyz; ERROR 1194 (HY000): Table 'xyz' is marked as crashed and should be repaired

Also, we saw high iowait time (90%) for 1 min in every 3 min cycle.

Has anyone seen this problem before?


I realize this is horrendously late and the problem has probably been solved by now, but:
We used to see myisam crashes and table corruption under load. A switch to innodb solved that completely. Subsequent performance issues were resolved by flipping transaction commit frequency to per-second rather than per-write. Innodb is faster and far more stable for us than myisam ever was. In 2.5 years, we haven’t had a single outage apart from the time that I accidentally uninstalled the binaries out from under the running server.