missing Percona-server-devel for version 5.6 in debian apt

Hi

I have been struggling to install devel package but no luck. kindly advise.

Logs

root@instance-5:/usr/lib/x86_64-linux-gnu# apt-get install Percona-Server-devel*
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package Percona-Server-devel*
E: Couldn’t find any package by regex ‘Percona-Server-devel*’

root@instance-5:/home/cpsmscin/gateway-svn# /usr/bin/mysql_config
Usage: /usr/bin/mysql_config [OPTIONS]
Options:
–cflags [-I/usr/include/mysql -g -fno-strict-aliasing -fPIC -g -static-libgcc -fno-omit-frame-pointer -fno-strict-aliasing -DMY_PTHREAD_FASTMUTEX=1]
–include [-I/usr/include/mysql]
–libs [-L/usr/lib/x86_64-linux-gnu -lperconaserverclient -lpthread -lm -lrt -lssl -lcrypto -ldl]
–libs_r [-L/usr/lib/x86_64-linux-gnu -lperconaserverclient_r -lpthread -lm -lrt -lssl -lcrypto -ldl]
–plugindir [/usr/lib/mysql/plugin]
–socket [/var/run/mysqld/mysqld.sock]
–port [0]
–version [5.5.44-37.3]
–libmysqld-libs [-L/usr/lib/x86_64-linux-gnu -lmysqld]
–variable=VAR VAR is one of:
pkgincludedir [/usr/include/mysql]
pkglibdir [/usr/lib/x86_64-linux-gnu]
plugindir [/usr/lib/mysql/plugin]
root@instance-5:/home/cpsmscin/gateway-svn# cd /usr/lib/x86_64-linux-gnu/
root@instance-5:/usr/lib/x86_64-linux-gnu# ls -l libmysql*
lrwxrwxrwx 1 root root 20 Jul 16 04:22 libmysqlclient_r.so.18 -> libmysqlclient.so.18
lrwxrwxrwx 1 root root 24 Jul 16 04:22 libmysqlclient_r.so.18.0.0 -> libmysqlclient.so.18.0.0
lrwxrwxrwx 1 root root 24 Jul 16 04:22 libmysqlclient.so.18 -> libmysqlclient.so.18.0.0
-rw-r–r-- 1 root root 3424672 Jul 16 04:22 libmysqlclient.so.18.0.0
root@instance-5:/usr/lib/x86_64-linux-gnu# ls -l libper*.*
-rw-r–r-- 1 root root 3877834 Jul 1 10:13 libperconaserverclient.a
lrwxrwxrwx 1 root root 24 Jul 1 10:13 libperconaserverclient_r.a -> libperconaserverclient.a
lrwxrwxrwx 1 root root 25 Jul 1 10:13 libperconaserverclient_r.so -> libperconaserverclient.so
lrwxrwxrwx 1 root root 28 Jul 8 13:26 libperconaserverclient_r.so.18 -> libperconaserverclient.so.18
lrwxrwxrwx 1 root root 32 Jul 1 10:13 libperconaserverclient_r.so.18.0.0 -> libperconaserverclient.so.18.0.0
lrwxrwxrwx 1 root root 32 Jul 8 13:26 libperconaserverclient_r.so.18.1.0 -> libperconaserverclient.so.18.1.0
lrwxrwxrwx 1 root root 28 Jul 1 10:13 libperconaserverclient.so -> libperconaserverclient.so.18
lrwxrwxrwx 1 root root 32 Jul 8 13:26 libperconaserverclient.so.18 -> libperconaserverclient.so.18.1.0
-rw-r–r-- 1 root root 3095168 Jul 1 10:13 libperconaserverclient.so.18.0.0
-rw-r–r-- 1 root root 3504176 Jul 8 13:26 libperconaserverclient.so.18.1.0

checking for /opt/local/share/dsssl/docbook-dsssl/print/docbook.dsl… no
Not building documentation.

Configuring parameters …
checking which malloc to use… native malloc
enabling local time
enabling cookies
enabling HTTP/1.1 keep-alive

Configuring OpenSSL support …
checking whether to compile with SSL support… trying

Configuring DB support …
checking whether to compile with MySQL support… searching
checking for mysql_config… /usr/bin/mysql_config
checking mysql version… 5.5.44-37.3
checking mysql reentrant libs… -L/usr/lib/x86_64-linux-gnu -lperconaserverclient_r -lpthread -lm -lrt -lssl -lcrypto -ldl
checking for mysql_init in -lmysqlclient_r… no
checking mysql libs… -L/usr/lib/x86_64-linux-gnu -lperconaserverclient -lpthread -lm -lrt -lssl -lcrypto -ldl
checking for mysql_init in -lmysqlclient… no
configure: error: Unable to find MySQL client libraries

As per the suggestion of this documentation of cpanel
https://documentation.cpanel.net/dis…L+with+Percona

I tried doing the same
ln -sv /usr/lib64/libperconaserverclient.so /usr/lib64/libmysqlclient.so

root@instance-5:/home/cpsmscin/gateway-svn# uname -ar
Linux instance-5 3.16.0-0.bpo.4-amd64 #1 SMP Debian 3.16.7-ckt11-1~bpo70+1 (2015-06-08) x86_64 GNU/Linux
root@instance-5:/home/cpsmscin/gateway-svn# mysql --version
mysql Ver 14.14 Distrib 5.6.25-73.1, for debian-linux-gnu (x86_64) using 6.2

But NO LUCK :frowning:

recently i tried installing the percona-server-source-5.6 but still no progress. kindly advise.

dpkg -l | grep -i percona

root@instance-5:/home/cpsmscin/gateway-svn# dpkg -l | grep -i percona
rc libmysqlclient18.1 5.6.15-25.5-759.wheezy amd64 Percona XtraDB Cluster database client library
ii libperconaserverclient18.1 5.6.25-73.1-1.wheezy amd64 Percona Server database client library
ii percona-server-5.6-dbg 5.6.25-73.1-1.wheezy amd64 Debugging package for Percona Server
ii percona-server-client-5.6 5.6.25-73.1-1.wheezy amd64 Percona Server database client binaries
ii percona-server-common-5.6 5.6.25-73.1-1.wheezy amd64 Percona Server database common files (e.g. /etc/mysql/my.cnf)
ii percona-server-server-5.6 5.6.25-73.1-1.wheezy amd64 Percona Server database server binaries
ii percona-server-source-5.6 5.6.25-73.1-1.wheezy amd64 Percona Server 5.6 source

apt-cache search libpercona

libperconaserverclient-dev - Percona Server database development files
libperconaserverclient18 - Percona Server database client library
libperconaserverclient18-dev - Percona Server database development files
libperconaserverclient18.1 - Percona Server database client library
libperconaserverclient18.1-dev - Percona Server database development files

In your case install libperconaserverclient18.1-dev, please try it out and let us know.

The solution was as stated:
sudo apt-get install libperconaserverclient18.1-dev

I am getting the below errors when I am trying to install percona 5.6 on ubunutu 14.4

percona-server-server-5.6 : Depends: percona-server-client-5.6 (>= 5.6.38-83.0-1.trusty) but it is not going to be installed
Depends: libdbi-perl but it is not installable
Depends: libdbd-mysql-perl but it is not installable
Depends: libaio1 (>= 0.3.93) but it is not installable
E: Unable to correct problems, you have held broken packages.

Not sure what should I do I tried all option pleaase help