log-copy-interval param error

Hello.
When i try to create backup error occurs.

Log here:

[root@arara390 ~]# innobackupex /home/backup/percona

InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
and Percona Ireland Ltd 2009-2012. All Rights Reserved.

This software is published under
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

130704 10:29:28 innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_group=xtrabackup' (using password: NO).
130704 10:29:28 innobackupex: Connected to MySQL server
IMPORTANT: Please check that the backup run completes successfully.
At the end of a successful backup run innobackupex
prints "completed OK!".

innobackupex: Using mysql server version 5.5.28-MariaDB-log

Unknown suffix '/' used for variable 'log-copy-interval' (value '/var/log/mysqld.log')
xtrabackup_55: Error while setting value '/var/log/mysqld.log' to 'log-copy-interval'
innobackupex: fatal error: no 'mysqld' group in MySQL options

Can you post here the full my.cnf configuration file?

Hi, I have same problem. Here is my.cnf file:


[mysqld]
datadir=/var/lib/mysql

log=/var/log/mysql.log
log-error=/var/log/mysql.err

binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2

wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_node_name=node-2
wsrep_cluster_name=test_cluster
wsrep_cluster_address=gcomm://10.0.3.57
wsrep_sst_auth=root:test
wsrep_sst_method=xtrabackup

Hi, for me the issue appeared with version 2.1 of percona-wtrabackup on debian.

With version 2.0 i had this warning message, and backup was done :


xtrabackup_55: ambiguous option '--log=/var/log/mysql/mysql.log' (log-copy-interval, log-stream)

With version 2.1 this is not a warning message, but and error message, and backup is not done:


Unknown suffix '/' used for variable 'log-copy-interval' (value '/var/log/mysql/mysql.log')
xtrabackup_55: Error while setting value '/var/log/mysql/mysql.log' to 'log-copy-interval'

The “log” option in /etc/my.cnf is deprecated, use general_log instead. See: https://kb.askmonty.org/en/server-system-variables/#log

BTW for old servers for which “log” is the correct way to set it up:
innobackupex: Error: Support for MySQL 5.1 with builtin InnoDB (not the plugin) was removed in Percona XtraBackup 2.1. The last version to support MySQL 5.1 with builtin InnoDB was Percona XtraBackup 2.0. at /usr/bin/innobackupex line 389.

Thanx themr0c, I had the same problem, and after changing from log to general_log everything working fine!.