Issues running 3.0.8 on CentOS 6


I have a Vagrant box I’m trying to install Percona Server for MongoDB on. I run “yum install Percona-Server-MongoDB -y” then “service mongod start” but I get the following:

[root@localhost vagrant]# service mongod start
Starting mongod: [FAILED]
[root@localhost vagrant]#

I then try this:

[root@localhost vagrant]# mongod -f /etc/mongod.conf
2016-01-05T13:56:49.722-0800 I STORAGE Compression: snappy
2016-01-05T13:56:49.722-0800 I STORAGE MaxWriteMBPerSec: 1024
2016-01-05T13:56:49.722-0800 I STORAGE Crash safe counters: 0
about to fork child process, waiting until server is ready for connections.
forked process: 16711
ERROR: child process failed, exited with error number 1

Any idea why this is happening? Googling didn’t help, and I’d previously been able to get a 3.x release candidate version to work. The box is using a fully updated copy of CentOS 6.



Hi Victorio,

Could you post mongod.log content ?


There’s nothing in my log file directory:

[root@localhost /]# ls /var/log/mongo/
[root@localhost /]#

Hi vchav73,

What about dmesg? If I were to start debugging an issue like this one - where you don’t get any useful output from the error - I would use strace or even gdb as well. I recommend you do your stuff within a tmux instance for more comfort.


Seems there was a problem with the conf file I was using. Funny thing is the same conf file worked with the last release candidate. I rebuilt it using the repo’s default conf file as a template and it’s working fine now. Thanks for all the help!