Installation error validating data: unknown object type “nil” in PerconaPGCluster.spec.secretsName

A new fresh install with operator version 1.1.0 on a Kubernetes cluster version 1.17

helm install pg-operator percona/pg-operator --version 1.1.0 --namespace postgre
helm install my-db percona/pg-db --version 1.1.0 --namespace postgre
Error: INSTALLATION FAILED: unable to build kubernetes objects from release manifest: error validating "": error validating data: unknown object type "nil" in PerconaPGCluster.spec.secretsName

An error comes up: error validating data: unknown object type “nil” in PerconaPGCluster.spec.secretsName

What is wrong? How to fix it?

1 Like

We have not tested 1.1.0 on k8s 1.17 version.
At the time of release 1.22 was already available and here you can see the list of the platforms we tested on: Percona Distribution for PostgreSQL Operator 1.1.0

In 1.16 and 1.17 there were multiple changes in the basic APIs, so it might be the reason.

Any reason why you use 1.17?

1 Like