"InnoDB: Fatal error: cannot read from file. OS error number 17" while restoring

Hello,

I’ve encountered this problem while restoring backup using innobackupex. So I started to investigate. It appeared that innobackupex runs the following command:

xtrabackup_55 --defaults-file="/home/backup/2013-11-24_00-00-03/backup-my.cnf" --defaults-group="mysqld" --prepare --target-dir=/home/backup/2013-11-24_00-00-03 --tmpdir=/tmp 

I ran strace and this this what I’ve got:

write(2, "InnoDB: Fatal error: cannot read"..., 64InnoDB: Fatal error: cannot read from file. OS error number 17.
) = 64
write(2, "131125 16:59:33", 15131125 16:59:33) = 15
write(2, " InnoDB: Assertion failure in t"..., 82 InnoDB: Assertion failure in thread 139988670924576 in file os0file.c line 2722

Backup was performed with xtrabackup-2.1.5-680 from PXC node. I am trying to restore it with the same version. Packages versions are:

percona-release-0.0-1.x86_64
Percona-XtraDB-Cluster-client-5.5.34-23.7.6.565.rhel6.x86_64
percona-toolkit-2.2.5-2.noarch
Percona-Server-shared-compat-5.5.34-rel32.0.591.rhel6.x86_64
percona-playback-0.7-2.el6.x86_64
Percona-XtraDB-Cluster-galera-2.8-1.162.rhel6.x86_64
percona-xtrabackup-2.1.5-680.rhel6.x86_64
Percona-XtraDB-Cluster-server-5.5.34-23.7.6.565.rhel6.x86_64
Percona-XtraDB-Cluster-shared-5.5.34-23.7.6.565.rhel6.x86_64

At the same time I know error 17 means:

[root@db1 ~]# perror 17
OS error code 17: File exists
[root@db1 ~]#

So I am bit confused. innobackupex completes without any visible error: “innobackupex: completed OK!”. There’s more than 100GB of free space and I’m under root account on Centos box. SELinux is in permissive mode. Files were transfered to this server from PXC node using rsync (with checksums). I’ve also tried few other servers to restore on and had the same error. I would appreciate if somebody could help me with this issue. If you need any additional information please let me know.
Thank you in advance