innodb_buffer_pool_size ignored

I want to increase innodb_buffer_pool_size by setting in /etc/my.cnf under [mysqld]

innodb_buffer_pool_size = 6144M

problem is, that it is ignored:

http://screencast.com/t/pUoLCEWdx

what could be the reason?

latest percona server
ubuntu 12.04

Few things to Check,

  1. See if there is no duplicate parameter set for innodb_buffer_pool_size.
  2. Check if the mysql is using /etc/my.cnf

Also if you could paste the my.cnf that would be good to check for errors.

ah, I’m stupid. I had another .cnf file in /etc/mysql/conf.d which overwrites the variables. everything is fine now :slight_smile: