I did the following

  1. downloaded innobackupex - 3827/download/head:/innobackup1.5.1-20090305061108-fxjvmhr91 4de7q81-1/innobackupex

  2. environment- windows server 2008 R2 Datacenter, 64Bit operating system, Active pearl

  3. Grant permissions to root user -
    Grant RELOAD, LOCK TABLES, REPLICATION CLIENT, FILE on . to ‘root’@‘localhost’ identified by ‘XXXXXXX’;
    as recommended in rivileges.html

  4. Flush privileges;

  5. Execute Innobackupex - $ “C:/Program Files/xtrabackup-1.6.64bit/” --defaults-file=“C:/Program Files/MySQL/MySQLInstance2/my.ini” --user=root --password=XXXXXXX D:/Xtrabackup/13306_1

I receive this error Starting mysql with options: --password=‘XXXXXXX’ --user=‘root’ --unbuffered –
111220 10:28:36 Connected to database with mysql child process (pid=4740) Error: mysql child process has died: ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES)

does anyone have any idea what privilege is needed by this “mysql child process” or what to do to stop this?

Hi all, i am yet to solve this problem, but for testing purposes i implemented a workaround i have added the SKIP-GRANT-TABLES option in my .ini file and restarted mysql. Innobackupex now works. please note that this is on a dev instance so dont do this in production. i do hope that someone can find out why innobackupex was getting itself in a tight spot there with privileges on mysql.

That’s not a privileges problem, it’s an error with login credentials (authentication - not authorization).