innobackupex not working properly in a MySQL Multi Instance Setup

I’m in the process of testing innobackupex in a multi instance setup. So two ports, one 3306 and the other 3308.

When I supply the innobackupex command, it says it’s connecting to the right place (3308), but the seeems to be backing up data from the default port (3306). As I supply a list of databases to backup, the resulting backup is pretty much useless.

The command I run
perl /usr/local/bin/mysql-backups/innobackupex-1.5.1 --port=3308 --slave-info --databases="" --user= --password= --stream=tar . | gzip - > dbbackup-3308.tar.gz

The output
110805 11:53:11 innobackupex-1.5.1: Starting mysql with options: --password=***** --user=***** --port=3308 --unbuffered –

xtrabackup: innodb_data_home_dir = /var/lib/mysql
xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend
xtrabackup: innodb_log_group_home_dir = /var/lib/mysql

The innodb parameters it says there are for the default port of 3306 and not 3308, so it’s pulling the wrong part out of the my.cnf. Plus if I check the processlist for 3306 when the backup starts, I can see the backup process in there.

Is there something I am doing wrong? Has anyone got this to work before? I even tried specifying the 3308 socket file, but no joy there either.

Help?

Are you using the grouped mysqld instances on your my.cnf? The xtrabackup binary does not support this feature yet (I was trying to hack it with my primitive C but could only progress like a baby).

What you can do is create separate *.cnf file for each instance with a minimum content like below for port 3308:

my3308.cnf

[mysqld]
datadir=/path/to/mysql/dir