innobackupex --copy-back does not copy-back

After a successful backup and apply-log I tried --copy-back.

But I get the following text in the output before it errors out.

“Original InnoDB data directory is not empty! at /opt/mysql/backup/bin/innobackupex line 571.”

I emptied the datadir and it returned the same error.

I tried it two times:

  • one with --defaults-file set
  • one run without --defaults-file set

I get the same result.

A bit more information:

I have basedir for the database on a NFS mount mount point (e.g. /nfsvol1/mysql/data) - this is where schema, log files,etc exist…

I have innodb ibdata files spread across 3 NFS mount points(e.g. /nfsvol2/mysql/data, /nfsvol3/mysql/data and /nfsvol4/mysql/data)

This is a total of 4 NFS mount points (I do this to optimize throughput to/from NFS). Spreading data across multiple point points is also recommended in netapps "best practices white papers:

Because of this I have: innodb_home_dir = /
I have innodb_data_file_path = nfsvol2/mysql/data/ibdata1:10G;fsvol3/mysql/data/ibdata2:10 GB;fsvol4/mysql/data/ibdata3:10G…

So the question is: Is it possible that I am getting this error because innodb_home_dir = / - certainly this is not empty, nor can it me.

Please advise - I really want to use innobackupex and I need to get copy-back working.

If this is the issue (not sure): I guess I could have absolute path names for the data files in innodb_data_file_path but the question is can I set innodb_home_dir to some directory that is empty?

Any help would be appreciated