innobackup restore database

After having backed up a database using innobackupex and the preparing the backup for restore I have run innobackupex --copy-back.
The process appears to work ok but at the end of the restore I get the following message.
Total output of 126.5Kib was truncated at 97.65Kib. Does this mean that the restore process has not completed properly.

Hello ericwm could you update this with information about database, OS and innobackupex versions.
Is this a backup that worked well in the past or a new experiment?
Did you get any error logs written (DB or OS)?

Hi Thank you for responding. The OS is Ubuntu16.04, Mysq Database is 14.14 Distrib 5.7.29 and Xtrabackup is 2.3.10-1.xenial. This is a first time installation.
Apologies for the misleading initial post - I have tried running a backup again and notice that it is not in fact completing correctly - this is from the terminal after running innobackupex -
200303 15:01:56 version_check Connecting to MySQL server with DSN ‘dbi:mysql:;mysql_read_default_group=xtrabackup’ as ‘root’ (using password: YES). 200303 15:01:56 version_check Connected to MySQL server 200303 15:01:56 version_check Executing a version check against the server… 200303 15:01:56 version_check Done. 200303 15:01:56 Connecting to MySQL server host: localhost, user: root, password: set, port: not set, socket: not set Using server version 5.7.29-0ubuntu0.16.04.1 innobackupex version 2.4.18 based on MySQL server 5.7.26 Linux (i686) (revision id: 29b4ca5) xtrabackup: uses posix_fadvise(). xtrabackup: cd to /var/lib/mysql xtrabackup: open files limit requested 0, set to 1024 xtrabackup: using the following InnoDB configuration: xtrabackup: innodb_data_home_dir = . xtrabackup: innodb_data_file_path = ibdata1:12M:autoextend xtrabackup: innodb_log_group_home_dir = ./ xtrabackup: innodb_log_files_in_group = 2 xtrabackup: innodb_log_file_size = 50331648 InnoDB: Number of pools: 1 200303 15:01:56 >> log scanned up to (1805786664) xtrabackup: Generating a list of tablespaces InnoDB: Allocated tablespace ID 48 for phpmyadmin/pma__favorite, old maximum was 0 200303 15:01:57 >> log scanned up to (1805786664) 200303 15:01:57 [01] Copying ./ibdata1 to /Backup/mysql/2020-03-03_15-01-56/ibdata1 200303 15:01:58 >> log scanned up to (1805786664) 200303 15:01:59 >> log scanned up to (1805786664)
This is followed by many lines of copying tables and then ends with- Total output of 144.56 kiB was truncated at 97.65 kiB.
(I am not sure whether this just means that the log output to the terminal is truncated or something in the actual backup) There is no Completed OK message.

Hello, I have solved this problem - I am using Webmin Terminal to run innobackupex and I have discovered that there is a configurable limit of output that can be captured by the terminal from commands. I increased this limit and now I no longer get the Total output of 144.56 kiB was truncated at 97.65 kiB. warning. and now see Completed Ok.
So problem was with Webmin and not innobackupex. Apologies for the confusion.

No problem at all and thank you for the update, as it could help someone else in the future :slight_smile:

We would, though, strongly encourage you to upgrade your version of Percona XtraBackup to 2.4 as 2.3 has been EoL for a while now (end of 2018) [URL][/URL]