Increasing Memory and Swap usage until full

Hi,

i have a 3 node percona xtradb cluster, server version 5.7.17-13-57-log, based on debian 8
each machine has 10GB ram and 10 virtual cpu of the host hyperv

each node has this my.cnf with only required value changed

The MySQL database server configuration file.

You can copy this to one of:

- “/etc/mysql/my.cnf” to set global options,

- “~/.my.cnf” to set user-specific options.

One can use all long options that the program supports.

Run program with --help to get a list of available options and with

–print-defaults to see which it would actually understand and use.

For explanations see

http://dev.mysql.com/doc/mysql/en/server-system-variables.html

This will be passed to all mysql clients

It has been reported that passwords should be enclosed with ticks/quotes

escpecially if they contain “#” chars…

Remember to edit /etc/mysql/debian.cnf when changing the socket location.

[client]
port = 3306
socket = /var/run/mysqld/mysqld.sock

Here is entries for some specific programs

The following values assume you have at least 32M ram

This was formally known as [safe_mysqld]. Both versions are currently parsed.

[mysqld_safe]
socket = /var/run/mysqld/mysqld.sock
nice = 0

[mysqld]
skip-name-resolve
performance_schema=OFF

* Basic Settings

user = mysql
pid-file = /var/run/mysqld/mysqld.pid
socket = /var/run/mysqld/mysqld.sock
port = 3306
basedir = /usr
datadir = /var/lib/mysql/data
tmpdir = /tmp
lc-messages-dir = /usr/share/mysql
skip-external-locking

Instead of skip-networking the default is now to listen only on

localhost which is more compatible and is not less secure.

bind-address = 0.0.0.0

* Fine Tuning

#key_buffer = 16M
max_allowed_packet = 16M
thread_stack = 192K
thread_cache_size = 50

This replaces the startup script and checks MyISAM tables if needed

the first time they are touched

#myisam-recover = BACKUP
max_connections = 500
#table_cache = 64
#thread_concurrency = 10

* Query Cache Configuration

query_cache_limit = 1M
#query_cache_size = 16M

* Logging and Replication

Both location gets rotated by the cronjob.

Be aware that this log type is a performance killer.

As of 5.1 you can enable the log at runtime!

#general_log_file = /var/log/mysql/mysql.log
#general_log = 1

Error log - should be very few entries.

log_error = /var/log/mysql/error.log

Here you can see queries with especially long duration

slow_query_log_file = /var/log/mysql/mysql-slow.log
slow_query_log = 1
long_query_time = 120
#log_queries_not_using_indexes

The following can be used as easy to replay backup logs or for replication.

note: if you are setting up a replication slave, see README.Debian about

other settings you may need to change.

#server-id = 1
#log_bin = /var/log/mysql/mysql-bin.log
expire_logs_days = 10
max_binlog_size = 100M
#binlog_do_db = include_database_name
#binlog_ignore_db = include_database_name

* InnoDB

InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.

Read the manual for more InnoDB related options. There are many!

* Security Features

Read the manual, too, if you want chroot!

chroot = /var/lib/mysql/

For generating SSL certificates I recommend the OpenSSL GUI “tinyca”.

ssl-ca=/etc/mysql/cacert.pem

ssl-cert=/etc/mysql/server-cert.pem

ssl-key=/etc/mysql/server-key.pem

#path to galera library
wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_provider_options=“gcache.size=30G”

#cluster connection url
wsrep_cluster_address=gcomm://easycluster1,easycluster2,easycluster3
wsrep_node_address=easycluster3

#metodo di sst
wsrep_sst_method=xtrabackup-v2

binlog_format=ROW
default_storage_engine=InnoDB
innodb_log_file_size=4G

#InnoDB autoincrement locks mode (Galera requires it to be 2)
innodb_autoinc_lock_mode=2
innodb_file_per_table=1
lower_case_table_names=1

#cluster name
wsrep_cluster_name=easyprofit_cluster

#authentication for sst method
wsrep_sst_auth=“sstuser:s3cretPass”

#tuning
innodb_flush_method=O_DIRECT
innodb_sort_buffer_size=64M
max_heap_table_size=64M
tmp_table_size=64M
wsrep_slave_threads=4
sort-buffer-size=64M
query-cache-type=0
query-cache-size=0

open-files-limit=65535
table-definition-cache=1024
table-open-cache=2048

innodb-buffer-pool-size=4G

[mysqldump]
quick
quote-names
max_allowed_packet = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
#key_buffer = 16M

* IMPORTANT: Additional settings that can override those from this file!

The files must end with ‘.cnf’, otherwise they’ll be ignored.

!includedir /etc/mysql/conf.d/

when each node is started, even if there are no activity from any client, the use of the memory increase slowly. when all 10 GB of memory is full, the swap usage begin increase until filled too. the swap is 14 GB.

when the memory and swap are filled, the OOM kill mysql process

If i give each machine other 5GB of memory, even that additional 5GB are used, without sense

i have already tried to limit caches or buffers, or opened tables/files but without success.

someone has the same problem?