how to get {master_log_file,mater_log_pos} when gtid_mode is enabled

GTID is enabled on my instance. when using xtrabackup with 1) --slave-info 2) --prepare options, there is only master_auto_position option in the xtrabackup_slave_info file, instead of master_log_file and master_log_pos.

Is there any option available on the current versions for my need? I need to pass {file,pos} to mysqlbinlog, which is used to taking back up binlogs every full backup later.

thanks in advance!

This link contains steps https://www.percona.com/doc/percona-xtrabackup/LATEST/howtos/recipes_ibkx_gtid.html

Can you provide exact command used and listing of backup directory. Along with that version you are using.

$ xtrabackup --version

Sorry for my pool english…it might be not clear to clarify my issue before. Actually I only need {file, pos} from xtrabackup_slave_info, but I found that the --slave-info option could not get the pair value when gtid_mode is enabled.

a) As follow is my commands:
shell> ${xtrabackup} --defaults-file=${MYCNF} --slave-info --backup --target-dir=${localdir}/${bakdate}/ 2>${localdir}/xtrabackup_${bakdate}.log
shell>${xtrabackup} --defaults-file=${MYCNF} --prepare --target-dir=${localdir}/${bakdate}/ 2>${localdir}/xtrabackup_${bakdate}.log

b) xtrabackup version: 2.4.7

It seems like you are hitting this bug https://bugs.launchpad.net/percona-xtrabackup/+bug/1705193
Can you try Percona Xtrabackup 2.3.9 or 2.4.8 instead. In case, If still fails then provide listing of target directory and show us contents of xtrabackup_slave_info file

Thanks mirfan. I already read through the above bug. well I’m lucky to hit it :stuck_out_tongue: