How to disable the default collect metric?

Hello guys,

I would like disable some collection like : --disbale-collectors=perf_schema.eventsstatements

Seem it’s not working. How can I disable it?


Hi @JasonTJ ,

Collectors are used by PMM to get metrics. PMM starts the MongoDB exporter by default only with diagnosticdata and replicasetstatus collectors enabled.

From your statement, it seems like you are trying to disable collections. In PMM, you can mention the database/collections for which you want to collect stats by using “–stats-collections”


For more details, kindly refer to below Percona documention -

NOTE: Collectors in PMM does not mean mongodb collections


Thanks for your updates!

I would like to disable some metrics collection for MYSQL database:

LIke : --disbale-collectors=perf_schema.eventsstatements

It does not work.


Hi @JasonTJ

Thanks for the clarification. From the above statement below are 2 points which needs modification.

  1. Spell check for “–disbale-collectors” ==> It should be “–disable-collectors
  2. Modification in collector “perf_schema.eventsstatements” ==> It should be “perf_schema.events_statements

Below are the list of collectors for MySQL from github repo.