How to bootstrap with "--lower-case-table-names=1"

For a POC I’m trying to conpare Percona XtraDB Cluster 8 on Ubuntu 18.04 and Kubernetes.
Using the documentation everything works fine and I’m able to setup a 3 node cluster on both.
Our devs came back with the requirement of "lower_case_table_names=1"
Kubernetes works by adding in the deploy/cr.yaml: 
[mysqld]
lower-case-table-names=1
However a a new VM Ubuntu 18.04 cluster this does not work by adding the same to /etc/mysql/mysql.conf.d/mysqld.cnfThe bootstrap fails. (sudo systemctl start mysql@bootstrap.service)
Even if I change it to lower_case_table_names=1
What am I doing wrong?

####
Jun 05 15:11:51 db1 systemd[1]: Starting Percona XtraDB Cluster with config /etc/default/mysql.bootstrap…-- Subject: Unit mysql@bootstrap.service has begun start-up-- Defined-By: systemd-- Support: http://www.ubuntu.com/support---- Unit mysql@bootstrap.service has begun starting up.Jun 05 15:11:56 db1 systemd[1]: mysql@bootstrap.service: Main process exited, code=killed, status=6/ABRTJun 05 15:11:56 db1 mysql-systemd[3636]:  WARNING: mysql pid file /var/run/mysqld/mysqld.pid empty or not readableJun 05 15:11:56 db1 mysql-systemd[3636]:  WARNING: mysql may be already deadJun 05 15:11:56 db1 systemd[1]: mysql@bootstrap.service: Failed with result ‘signal’.Jun 05 15:11:56 db1 systemd[1]: Failed to start Percona XtraDB Cluster with config /etc/default/mysql.bootstrap.-- Subject: Unit mysql@bootstrap.service has failed-- Defined-By: systemd-- Support: http://www.ubuntu.com/support---- Unit mysql@bootstrap.service has failed.---- The result is RESULT.
####

Hi @Bschwarzer
I was able to reproduce your issue on ubuntu 18.04 
If you check the error.log you will see message
[ERROR] [MY-011087] [Server] Different lower_case_table_names settings for server (‘1’) and data dictionary (‘0’).If you try to start MySQL 8 with a different value of lower_case_table_names than MySQL was initialized, you will get this message.
So you need to re-initialize data directory. 

Thank you for the answer. It works. Is there a simpler way to achieve the same end result starting from a completely new server?

@Bschwarzer
For now the only way is to re-init data directory after the installation. I have created Jira ticket to improve this case and add the ability to define this before installing package. So it should be fixed for next releases

Thank you very much for your support and the Jira ticket.