Hide password from ps display?

How do you prevent the password from appearing in the ps display?

The ~/.my.cnf file does not seem to be supported when using innobackupex version v1.5.1-xtrabackup and a --defaults-file command line option.

This is the command line I am using:

innobackupex --defaults-file=/data/mysql/master/DM02/etc/my.cnf ./

and this is the error:
130820 23:40:57 innobackupex: Connecting to MySQL server with DSN ‘dbi:mysql:;mysql_read_default_file=/data/mysql/master/P-DM02/etc/my.cnf;mysql_read_default_group=xtrabackup’ (using password: NO).
ERROR: Failed to connect to MySQL server: DBI connect(’;mysql_read_default_file=/data/mysql/master/DM02/etc/my.cnf;mysql_read_default_group=xtrabackup’,’’,… ) failed: Access denied for user ‘root’@‘localhost’ (using password: NO) at /usr/bin/innobackupex line 1601

Here is the ~/.my.cnf file:

When I use this command everything works fine (except the password appears in ps):

innobackupex --defaults-file=/data/mysql/master/DM02/etc/my.cnf --user=root --password=‘p@ssword’ ./


Hi Ross,

Actually, its natural behavior of any Percona command line utility that if you specify a defaults file explicitly with –defaults-file option, then implicit ones like ~/.my.cnf will not parsed. So in your case if you want to use both files then you can use “!include” option to apply settings of .my.cnf file by adding it at the end of regular my.cnf file.

add “!include /root/.my.cnf” line at the end of /data/mysql/master/PAXUS-DM02/etc/my.cnf and try to run
innobackupex --defaults-file=/data/mysql/master/PAXUS-DM02/etc/my.cnf ./

Please let me know if face any issue. Thanks.

Could you delete this post please?