help using tablespaces on multiple disks

I have a configuration like this:

I have tables set up in tablespaces such as

Each database in my installation lives on a separate logical volume
A typical table statement will include DATA DIRECTORY=’/usr/local/sg/mysqldata/services/’; - the database lives in /usr/local/sg/mysqldata/services/services

My problem comes in that when trying to bring the other two servers online I have tried:
xtradbbackup_v2 – basically remove everything from the datadir and starting mysql … this causes various errors when syncing but does create the .frm and .isl files.

When I set the datadir to /usr/local/sg/mysqldata it does create the services directory and puts the ibd, isl and frm files there … however on my “real” servers my directory structure is (example)
/dev/mapper/VolGroup03-LogVol00 …. /usr/local/sg/mysqldata/services
Q - So my question is … with datadir pointed at /usr/local/sg/mysqldata will xtradbbackup load the data into the actual data dir locations? (see DATA DIRECTORY statement above)
I am unable to get rsync to replicate data under any circumstance in this configuration as well.
I need to be able to exactly replicate my initial node configuration.

Any suggestions?

My wsrep parameters are
wsrep_provider_options = ‘socket.checksum = 1;’

wsrep_cluster_address=gcomm://<node 1>

I also find it interesting that even though my software appears to be the most recent … I can only get it to run with socket.checksum=1 set .

Last time I checked, xtrabackup worked well with custom data directories for tables.
What exactly PXC version are you using?:
rpm -qa|grep -i percona
dpkg -l|grep -i percona
Did you create the destination directories on joiner node, with proper file permissions, before you started the other nodes?
Can you paste these example errors?
Is either apparmor or selinux enabled?