Having issues with wsrep_sst_xtrabackup-v2

I am running an exact clone of 5.6 running on ubuntu.

Two Server Cluster, very simple stuff so I can get started with the software…

Followed as closely as possible from what I can tell to the tutorial.

Started using Bootstrap /init.d/ mode.
wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_cluster_address=gcomm://192.168.1.2,192.168.1.3,192.168.1.4
wsrep_node_address=192.168.1.2
default_storage_engine=InnoDB
wsrep_cluster_name=sociabledata
wsrep_sst_auth=“sstuser:s3cretPass”
binlog_format=ROW
innodb_locks_unsafe_for_binlog=1
innodb_autoinc_lock_mode=2
wsrep_sst_method=xtrabackup-v2

When attempting to connect this one…

We get this error.
wsrep_provider=/usr/lib/libgalera_smm.so
wsrep_cluster_address=gcomm://192.168.1.2,192.168.1.3
wsrep_node_address=192.168.1.3
default_storage_engine=InnoDB
wsrep_cluster_name=sociabledata
wsrep_sst_auth=sstuser:s3cretPass
binlog_format=ROW
innodb_locks_unsafe_for_binlog=1
innodb_autoinc_lock_mode=2
wsrep_sst_method=xtrabackup-v2

We get the log file error:

[ERROR] WSREP: Failed to read 'ready ’ from: wsrep_sst_xtrabackup --role ‘joiner’ --address ‘192.168.1.3’ --auth ‘sstuser:s3cretPass’ --datadir ‘/var/lib/mysql/’ --defaults-file '/etc/mysql$
Read: ‘(null)’

Which from what I can tell causes these next two and failure to make cluster.

2014-08-08 00:16:54 32680 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup --role ‘joiner’ --address ‘192.168.1.3’ --auth ‘sstuser:s3cretPass’ --datadir ‘/var/lib/mysql/’ --defaults-file '/etc/mysql/my.cn$
2014-08-08 00:16:54 32680 [ERROR] WSREP: Failed to prepare for ‘xtrabackup’ SST. Unrecoverable.

which then leads me to run this command as root

wsrep_sst_xtrabackup-v2 --role ‘joiner’ --address ‘192.168.1.3’ --auth ‘sstuser:s3cretPass’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/mysql/my.cnf’ --parent ‘273 48’ ‘’

Leading me to get this output:

[INFO] Streaming with xbstream (20140808 01:41:21.679)
WSREP_SST: [INFO] Using socat as streamer (20140808 01:41:21.681)
innobackupex: Error: Terminated with SIGPIPE at /usr/bin/innobackupex line 1710.
WSREP_SST: [INFO] Evaluating timeout -k 110 100 socat -u TCP-LISTEN:4444,reuseaddr stdio | xbstream -x; RC=( ${PIPESTATUS[@]} ) (20140808 01:41:21.893)
ready 192.168.1.3:4444/xtrabackup_sst
WSREP_SST: [ERROR] Possible timeout in receving first data from donor in gtid stage (20140808 01:43:01.896)
WSREP_SST: [ERROR] Cleanup after exit with status:32 (20140808 01:43:01.898)
WSREP_SST: [INFO] Removing the sst_in_progress file (20140808 01:43:01.900)

What I can do to solve this? I have spent almost 6 hours looking around now to make this work. Quite painful.

How about xtrabackup itself? Does the Xtrabackup at donor node work well?

Would you show me the log for donor as well?
There might be MySQL Error log & XtraBackup Log at the donor node.