Hash sum mismatch for percona-xtradb-cluster-5.7-dbg_5.7.31-31.45-3.xenial_amd64.deb


I am trying to install this package however we are getting an error:

apt-get install percona-xtradb-cluster-5.7

Reading package lists... Done

Building dependency tree

Reading state information... Done

Note, selecting 'percona-xtradb-cluster-5.7-dbg' for regex 'percona-xtradb-cluster-5.7'

The following NEW packages will be installed:


0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.

1 not fully installed or removed.

Need to get 191 MB of archives.

After this operation, 213 MB of additional disk space will be used.

WARNING: The following packages cannot be authenticated!


Install these packages without verification? [y/N] y

Get:1 http://repo.percona.com/apt xenial/main amd64 percona-xtradb-cluster-5.7-dbg amd64 5.7.31-31.45-3.xenial [191 MB]

Err:1 http://repo.percona.com/apt xenial/main amd64 percona-xtradb-cluster-5.7-dbg amd64 5.7.31-31.45-3.xenial

 Hash Sum mismatch

Fetched 167 MB in 7s (21.4 MB/s)

E: Failed to fetch http://repo.percona.com/apt/pool/main/p/percona-xtradb-cluster-5.7/percona-xtradb-cluster-5.7-dbg_5.7.31-31.45-3.xenial_amd64.deb  Hash Sum mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Hi @CostelLI tried to reproduce your issue but without success.

What commands I have executed to reproduce:

wget https://repo.percona.com/prel/apt/pool/main/p/percona-release/percona-release_1.0-25.generic_all.deb
sudo dpkg -i percona-release_1.0-25.generic_all.deb
sudo apt update
sudo apt-get install percona-xtradb-cluster-5.7

What I get in result:

vagrant@ubuntu-xenial:~$ dpkg -l | grep percona 
ii percona-release                  1.0-25.generic                            all         Package to install Percona gpg key and AP
T repos 
ii percona-xtrabackup-24            2.4.21-1.xenial                           amd64       Open source backup tool for InnoDB and Xt
ii percona-xtradb-cluster-5.7-dbg   5.7.31-31.45-3.xenial                     amd64       Debugging package for Percona XtraDB Clus
ii percona-xtradb-cluster-client-5.7 5.7.31-31.45-3.xenial                     amd64       Percona XtraDB Cluster database client bi
ii percona-xtradb-cluster-common-5.7 5.7.31-31.45-3.xenial                     amd64       Percona XtraDB Cluster database common fi
les (e.g. /etc/mysql/my.cnf) 
ii percona-xtradb-cluster-server-5.7 5.7.31-31.45-3.xenial                     amd64       Percona XtraDB Cluster database server bi


Maybe it’s the repo that I use. I have this:

cat /etc/apt/sources.list.d/percona.list
# PERCONA repo
deb http://repo.percona.com/apt xenial main
deb-src http://repo.percona.com/apt xenial main

The helper package seems to create (notice the extra percona in the path):

deb http://repo.percona.com/percona/apt xenial main

From the above it worked well.
I was trying to install:


Now I switched to install:


and this is ok because the “-dbg” is not a dependency.

We are doing the install automatically (via salt-stack) and it has been like it is now for a long time. I know for sure that it worked a couple of weeks ago because we did the exact same thing and there was no failure. I guess I just need to update to the new repo path and/or rebuild the install to use the helper package, but maybe there are others that use the old paths.

Thank you.

Usually such issue might appear in the following case:

packages in repo were updated but apt-cache on the system was not updated.

So try to perform apt-get update before the installation of dbg package

I had run it before (and anyway salt should have run it after adding the repo), however now I cannot reproduce it anymore.

I see that we get different IP addresses when doing dig, so maybe I was just getting to a bad mirror as you suggested.

Anyway I consider my question asked. Really really appreciate the quick responses.


I am glad that it works for you now. If you have any other questions - please create new topics :slight_smile: