Errors with Sharded Server Cluster on GKE

We tried install mongodb server with sharding enabled but keep getting this error on cfg pods: find: '/data/configdb': No such file or directory

We used latest psmdb-operator and psmdb-db helm charts.

GKE version is 1.26.3-gke.1000

In the cfg pod events we also get:

Error: failed to create containerd task: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: exec: "/data/db/": stat /data/db/ no such file or directory: unknown

In the logs also:

Exit: connect to PBM: create mongo connection: mongo ping: server selection error: server selection timeout, current topology: { Type: ReplicaSetNoPrimary, Servers: [{ Addr: localhost:27017, Type: RSGhost, Average RTT: 1196431 }, ] }"

Hi @Ben_Chiciudean ,

Kindly share the cr.yaml file and the describe pod output of the config server for further analysis.
Also the yaml output of config pod.

kubectl describe pod (pod name) -n (namespace)
kubectl get pod (pod name) -n (namespace) -o yaml


In the end we used the cr.yaml file which works, like I said previously we tried with psmdb-db helm chart and any values we passed to the release, it wouldn’t apply them. We have removed the helm release.