Enable Flashcache in 5.5

I’m running multiple servers with Percona/MySQL 5.1.16 and Flashcache, which works quite fine.

I’m now however having problems installing Percona/MySQL 5.5.19 on new servers with Flashcache, as the startup states there is a problem with the “Flashcache bypass”.

Output from a server running 5.5.19:

120118 03:51:25 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql120118 3:51:25 [Note] Flashcache bypass: disabled120118 3:51:25 [Note] Flashcache setup error is : ioctl failed120118 3:51:25 [Note] Plugin ‘FEDERATED’ is disabled.120118 3:51:25 InnoDB: The InnoDB memory heap is disabled120118 3:51:25 InnoDB: Mutexes and rw_locks use GCC atomic builtins120118 3:51:25 InnoDB: Compressed tables use zlib 1.2.3120118 3:51:25 InnoDB: Using Linux native AIO120118 3:51:25 InnoDB: Initializing buffer pool, size = 120.0G120118 3:51:31 InnoDB: Completed initialization of buffer pool120118 3:51:31 InnoDB: highest supported file format is Barracuda.120118 3:51:36 InnoDB: Waiting for the background threads to start120118 3:51:37 Percona XtraDB (http://www.percona.com) 1.1.8-rel24.0 started; log sequence number 324537592488120118 3:51:37 [Note] Slave SQL thread initialized, starting replication in log ‘mysql-bin.000104’ at position 74933008, relay log ‘/database/dblogs/mysql-relay-bin.000272’ position: 67383397120118 3:51:37 [Note] Event Scheduler: Loaded 0 events120118 3:51:37 [Note] /usr/sbin/mysqld: ready for connections.Version: ‘5.5.19-55-log’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona Server (GPL), Release rel24.0, Revision 204

If I however downgrade to Percona/MySQL 5.1.16 on the same server Flashcache works:

120118 05:48:12 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql120118 5:48:12 [Note] Flashcache bypass: enabled120118 5:48:12 [Note] Plugin ‘FEDERATED’ is disabled.InnoDB: The InnoDB memory heap is disabledInnoDB: Mutexes and rw_locks use GCC atomic builtinsInnoDB: Compressed tables use zlib 1.2.3120118 5:48:12 InnoDB: Initializing buffer pool, size = 120.0G120118 5:48:17 InnoDB: Completed initialization of buffer pool120118 5:48:17 InnoDB: highest supported file format is Barracuda.120118 5:48:22 Percona XtraDB (http://www.percona.com) 1.0.17-rel13.1 started; log sequence number 45356120118 5:48:22 [Note] Event Scheduler: Loaded 0 events120118 5:48:22 [Note] /usr/sbin/mysqld: ready for connections.Version: ‘5.1.60-rel13.1-log’ socket: ‘/var/lib/mysql/mysql.sock’ port: 3306 Percona Server (GPL), 13.1, Revision 413

Flashcache is mounted on /var/lib/mysql.

Is there a problem with Flashcache in Percona/MySQL 5.5, or does it wrongfully report that Flashcache bypass can’t be enabled?
Is there any way for me to validate that MySQL works correctly, besides seeing that our SSD harddrives work as expected?

I see the exact same thing with Percona 5.5.20 also. It would be nice to find out how to resolve this with out having to run 5.1.

I see no one else has responded and frankly I’m not sure – I’m not the expert in administering Flashcache. So you’re likely to get best results by engaging us for consulting.

got the same problem with 5.5.17+

anyone found a solution for this except downgrading to 5.1?

found something here: https://bugs.launchpad.net/percona-server/+bug/747032

adding

cd $datapath

into /etc/init.d/mysql fixes this problem.

cheers,

Juergen

Hi Juergen,

where exactly did you add that line in order to fix the issue? I’ve tried to add it, too, but the issue persists. (Please post the precise snippet!)

Thanks!

  • Denis