"Disk Read/Write Time per IO Request (ms)" - problem

Fresh Cacti 0.8.8f.
Fresh percona-monitoring-plugins-1.1.5

RRDTool Command:

/usr/bin/rrdtool graph -
–imgformat=PNG
–start=’-86400’
–end=’-300’
–title=‘aten.test.rmv - Disk Read/Write Time per IO Request (ms)’
–base=‘1024’
–height=‘120’
–width=‘500’
–alt-autoscale-max
–lower-limit=‘0’
–vertical-label=’’
–slope-mode
–font TITLE:10:
–font AXIS:7:
–font LEGEND:8:
–font UNIT:7:
DEF:a=’/srv/www/cacti.test.rmv/htdocs/cacti-0.8.8f/rra/aten_test_rmv_disk_reads_122.rrd’:‘DISK_reads’:AVERAGE
DEF:b=’/srv/www/cacti.test.rmv/htdocs/cacti-0.8.8f/rra/aten_test_rmv_disk_reads_122.rrd’:‘DISK_writes’:AVERAGE
CDEF:cdefa=‘c,a,/’
CDEF:cdefe=‘d,b,/,-1,*’
CDEF:cdeff=‘d,b,/’
AREA:cdefa#75637EFF:‘Read Time per IO’
GPRINT:cdefa:LAST:’ Cur:%6.1lf%s’
GPRINT:cdefa:AVERAGE:‘Avg:%6.1lf%s’
GPRINT:cdefa:MAX:‘Max:%6.1lf%s\n’
AREA:cdefe#81BFE0FF:‘Write Time per IO’
GPRINT:cdeff:LAST:‘Cur:%6.1lf%s’
GPRINT:cdeff:AVERAGE:‘Avg:%6.1lf%s’
GPRINT:cdeff:MAX:‘Max:%6.1lf%s\n’

RRDTool Says:
ERROR: invalid rpn expression in: c,a,/

Data Source [DISK_time_spnt_rdng]
The data source to use for this graph item.
and
Data Source [DISK_tme_spnt_wrtng]
The data source to use for this graph item.
is “none”

Other graphs are okay.

May be something changed with the new Cacti version.
Giving percona-cacti-templates 1.1.5, cacti 0.8.8b I have got:

/usr/bin/rrdtool graph -
–imgformat=PNG
–start=’-86400’
–end=’-300’
–title=‘cdba - Linux - Disk Read/Write Time per IO Request (ms)’
–base=‘1024’
–height=‘120’
–width=‘500’
–alt-autoscale-max
–lower-limit=‘0’
–vertical-label=’’
–slope-mode
–font TITLE:10:
–font AXIS:7:
–font LEGEND:8:
–font UNIT:7:
DEF:a=’/usr/share/cacti/rra/db1_-linux_disk_reads_118.rrd’:‘DISK_reads’:AVERAGE
DEF:b=’/usr/share/cacti/rra/db1
-linux_disk_reads_118.rrd’:‘DISK_writes’:AVERAGE
DEF:c=’/usr/share/cacti/rra/db1
-linux_disk_reads_118.rrd’:‘DISK_time_spnt_rdng’:A VERAGE
DEF:d=’/usr/share/cacti/rra/db1
-_linux_disk_reads_118.rrd’:‘DISK_tme_spnt_wrtng’:A VERAGE
CDEF:cdefa=‘c,a,/’
CDEF:cdefe=‘d,b,/,-1,*’
CDEF:cdeff=‘d,b,/’
AREA:cdefa#75637EFF:‘Read Time per IO’
GPRINT:cdefa:LAST:’ Cur:%6.1lf%s’
GPRINT:cdefa:AVERAGE:‘Avg:%6.1lf%s’
GPRINT:cdefa:MAX:‘Max:%6.1lf%s\n’
AREA:cdefe#81BFE0FF:‘Write Time per IO’
GPRINT:cdeff:LAST:‘Cur:%6.1lf%s’
GPRINT:cdeff:AVERAGE:‘Avg:%6.1lf%s’
GPRINT:cdeff:MAX:‘Max:%6.1lf%s\n’
COMMENT:’ ’
COMMENT:’ ’

Fresh Cacti 0.8.8b
Only installed cacti_host_template_percona_gnu_linux_server_ht_0.8.6i-sver1.1.5.xml
Same result! Something is missing!

HI!

I can not give more information. What should I see?
As I wrote to install only the cacti and cacti_host_template_percona_gnu_linux_server_ht_0. 8.6i-sver1.1.5.xml.
And the variables c and d can not be any values.
Is there anything templite is still necessary?

Hi,

I had the same problem, and I solved it. Here is how to solve it:

  1. Edit Graph Template, search “Percona Disk Read/Write Time per IO Request (ms) GT”

  2. In “Graph Item Inputs” you will find 4 items, click each to find out which one is configured wrong. In my config is Data Source [DISK_time_spnt_rdng] wrong, it should be Item #4: GPRINT (MAX), but configured Item #8: GPRINT (MAX)

  3. save and go to graph, you should see the correct graph.

BTW, I am using Cacti 1.1.28 + Percona 1.1.7 templates, and I am using 1 minute interval. Hope percona can check the compatibility with Cacti 1.1.x and add 1 minute settings.