Disable performance_schema queries


im using percona xtradb 8 + pmm2 under debian.
PMM2 frequently queries this select: “SELECT EVENT_NAME, COUNT_STAR, SUM_TIMER_WAIT FROM performance_schema.events_waits_summary_global_by_event_name”

After a few days, this queries getting slower and slower (1sec+), and i have to restart the nodes to avoid high CPU usage.

Is there any way to truncate/reset the statistics? Or any way to disable pmm2 to collect these metrics? In fact I just want to collect the slow queries to analyze.


Hello @domby,
You need to re-add the mysql server in question to PMM using the pmm-admin tool and specify that the slow query source is slowlog, and not perfschema. Check the --help of pmm-admin for the exact syntax.

@matthewb thanks, its working.