critical bug: pmm-client 1.1.3 mysql:queries exit with status 1

I’m facing trouble while upgrading

pmm-admin add mysql --user root --password password

[linux:metrics] OK, already monitoring this system.
[mysql:metrics] OK, now monitoring MySQL metrics using DSN root:***@unix(/data/mysql/mysql.sock)
[mysql:queries] Error adding MySQL queries: problem with agent registration on QAN API: exit status 1

Hi JoyG , my apologies for not answering your post sooner. May I suggest you remove the instance, and then re-add with --verbose so we can get greater detail for why the QAN part is failing?

pmm-admin remove mysql
pmm-admin add mysql --verbose

I am currently experiencing the same output when attempting to add the mysql:queries service to a fresh pmm-client installation.
Thus far I have not found a clear solution to the problem.

My verbose output is given in the txt file.

qan_api_error.txt (11.4 KB)

Hi Pomoens,

can you give me the version of your PMM Server and PMM Client?
Do you have enough free space inside PMM Server container?
Is pmm-admin tool has been run from root rights?

according to logs your application failed during run
see https://github.com/percona/pmm-client/blob/master/pmm/queries.go#L149-L164 for details
tool has debug flag.

can you run in debug mode and share output?
theoretically, needed command can look like this:

/usr/local/percona/qan-agent/bin/percona-qan-agent-installer -debug -mysql=false -server-user=USER -server-pass=PASSWORD PMM-IP

please use the following command if you are working via SSL

/usr/local/percona/ qan -agent/bin/percona- qan -agent-installer -debug -mysql=false -server-user=USER -server-pass=PASSWORD -use-insecure-ssl PMM-IP:443

I had same issue.

In my case, my docker mysql database was not up in docker.

so QAN was not ready to receive from client.

thanks.