Cp: cannot stat '/db/wallog/test_logs/00000002.history': No such file or directory

Why I am getting the below error in PostgreSQL14, can somebody please help on the below issue?

Version: PostgreSQL14

2022-08-25 16:58:41.738 UTC [13377] LOG: listening on IPv4 address “192.168.0.54”, port 5432
2022-08-25 16:58:41.739 UTC [13377] LOG: listening on Unix socket “/var/run/postgresql/.s.PGSQL.5432”
2022-08-25 16:58:41.744 UTC [13379] LOG: database system was interrupted; last known up at 2022-08-25 10:38:48 UTC
cp: cannot stat ‘/db/wallog/test_logs/00000002.history’: No such file or directory
2022-08-25 16:58:41.795 UTC [13379] LOG: starting point-in-time recovery to 2022-08-25 16:40:13+00
2022-08-25 16:58:41.994 UTC [13379] LOG: restored log file “000000010000003D000000FE” from archive
2022-08-25 16:58:42.364 UTC [13379] FATAL: recovery aborted because of insufficient parameter settings
2022-08-25 16:58:42.364 UTC [13379] DETAIL: max_connections = 100 is a lower setting than on the primary server, where its value was 550.
2022-08-25 16:58:42.364 UTC [13379] HINT: You can restart the server after making the necessary configuration changes.
2022-08-25 16:58:42.367 UTC [13377] LOG: startup process (PID 13379) exited with exit code 1
2022-08-25 16:58:42.367 UTC [13377] LOG: aborting startup due to startup process failure
2022-08-25 16:58:42.369 UTC [13377] LOG: database system is shut down
postgresql-2022-08-

1 Like

Hi Folks,

Can somebody help me on this?

1 Like

Hi Folks,

Can somebody help me on this?

1 Like

Hi,

Looking at your log output my understanding is that you are having issues with a REPLICA and that it won’t start up.

I suggest you look at this particular message, it appears you might not be using the same configuration parameters between PRIMARY and REPLICA:

2022-08-25 16:58:42.364 UTC [13379] FATAL: recovery aborted because of insufficient parameter settings
2022-08-25 16:58:42.364 UTC [13379] DETAIL: max_connections = 100 is a lower setting than on the primary server, where its value was 550.
2022-08-25 16:58:42.364 UTC [13379] HINT: You can restart the server after making the necessary configuration changes.

Hope this helps :slight_smile:

1 Like

Hi Naresh,

Whenever you modify the configuration parameters in Primary server,those
changes needs to apply manually in standby server.

If you do not perform changes in standby server,Standby server will
shutdown automatically with above error message.

Please change “max_connection” parameter in postgresql.conf file of standby
server according primary server and then start the Standby server.

Regards,
Naveed Shaikh

1 Like

Hi @robert.bernier and @naveed.shaikh

Thanks for the quick update.

If you don’t mind can you please share the Master and Replica settings, which I should change in the postgresql.conf file to configure the streaming replication.’
Can you please share the postgresql.conf parameter settings for both Primary and Replica servers.

I am confusing the streaming replication settings and config settings for the PostgreSQL 14 version.

1 Like

According to your log message the number of connections on the PRIMARY is much larger than what’s set on the REPLICA i.e. they should be either the same or the REPLICA maximum number of connections should be greater.

TIP: set all your runtime parameters, including those required for the REPLICA in the configuration files found on the PRIMARY and then copy it to the REPLICA. PostgreSQL knows if its a PRIMARY or REPLICA therefore only those parameters that apply to the respective host applies.

1 Like

Hi @robert.bernier

Thanks for the quick help. Its fixed now,

1 Like