could not able to register the pmm client

I had configured the pmm-server on docker container which is running on RHEL box, and installed the pmm - client on another rhel server. However when am trying to register the client it is giving below messages. Though am able to access the pmm server using pmm web interface.

pmm-admin config --server :8080

Detected address ‘’ is not locally bound.
This usually happens when client and server are on the different networks.

Use --bind-address flag to set locally bound address, usually a private one, while client address is public.
The bind address should correspond to the detected client address via NAT and you would need to configure port forwarding.

PMM server should be able to connect to the client address ‘’ which should translate to a local bind address.
What ports to map you can find from “pmm-admin check-network” output once you add instances to the monitoring.

Do you have private and public networks?
is pmm client and pmm server located in same private network?

both the pmm client and server located in same private network 10.67.%

pmm client tries setup connection with pmm server, after that pmm server detects source IP address of pmm client and return it back to pmm client.
if pmm client cannot find such IP address locally, it shows error message.

Detected address '%s' is not locally bound.
This usually happens when client and server are on the different networks.

Use --bind-address flag to set locally bound address, usually a private one, while client address is public.
The bind address should correspond to the detected client address via NAT and you would need to configure port forwarding.

PMM server should be able to connect to the client address '%s' which should translate to a local bind address.
What ports to map you can find from "pmm-admin check-network" output once you add instances to the monitoring.

do you have any king of proxy, NAT, port-forwarding?
Are PMM Server and PMM client located in the same subnet(broadcast domain)?

Both PMM Server and PMM Client are in same subnet (broadcast domain).

Below is the configuration:
Node 1: (example Ip - 1.2.3.4)
docker configured and it is running on IP - example 5.6.7.8
PMM server configured

Node 2: (Example IP - 1.2.3.5)
PMM Client installed
And trying to configure the client using below command, however it is failing

pmm-admin config --server 1.2.3.4:8080

Detected address ‘5.6.7.8’ is not locally bound.
This usually happens when client and server are on the different networks.

Use --bind-address flag to set locally bound address, usually a private one, while client address is public.
The bind address should correspond to the detected client address via NAT and you would need to configure port forwarding.

PMM server should be able to connect to the client address ‘172.17.42.1’ which should translate to a local bind address.
What ports to map you can find from “pmm-admin check-network” output once you add instances to the monitoring.

Not sure if I need to confiugre the docker on Node:2 as well.

Hi Naresh,

can you try the following command?

pmm-admin config --server PMM-SERVER-IP --bind-address PMM-CLIENT-IP --client-address PMM-CLIENT-IP

Hi,
I have tried above command with --server-user and --server-password. but it is giving below message

pmm-admin config --server-user XXXXX --server-password XXXX --server --bind-address --client-address

Unable to connect to PMM server by address: 10.67.1.37

Even though the server is reachable it does not look to be PMM server.
Check if the configured address is correct.

can you add port number?

pmm-admin config --server 10.67.1.37:8080 --bind-address 10.67.1.x --client-address 10.67.1.x 

Am able to configure the client with the above command, however it says below msgs when i see it in web interface

QAN API error: “qh.Profile: No query classes for selected instance and time range. Please check whether your MySQL settings match the recommended.”.
Check the /var/log/qan-api.log file in docker container for more information.

Looks like you don’t have new entries in slow log…
Query Analytics tools take queries from slow log, so please configure it
or you can switch “Collect from” to “Performance Schema” but it is not recommended.

have used : pmm-admin add mysql:queries --user XXXX --password XXXX

one more time
It is needed to configure Slow Log in Mysql
https://www.percona.com/doc/percona-monitoring-and-management/conf-mysql.html
https://www.a2hosting.com/kb/develop…y-log-in-mysql

OR you can start to use “Performance Schema” as query source (it is not recommended, but easier)
it is possible to do via Query Analytics interface
just choose database server, click on settings button (1), enable “query examples” (2) and set "“Performance Schema” in “Collect from” option (3)

query-examples.png