Compiling Xtrabackup 8.0.28-21 and OpenSSL 3.0.5

I have compiled Xtrabackup 8.0.28-21 from source with OpenSSL 1.1.1p but I have upgraded a system that only uses OpenSSL 3.0.5 [3.x series]. But whenever I try to compile Xtrabackup, it now shows the following message

-- Check size of off64_t
-- Check size of off64_t - done
-- Looking for fseeko
-- Looking for fseeko - found
-- Looking for unistd.h
-- Looking for unistd.h - found
-- Performing Test HAVE_CXX_W_missing_profile
-- Performing Test HAVE_CXX_W_missing_profile - Success
-- ZLIB_VERSION (bundled) is 1.2.11
-- ZSTD_LEGACY_SUPPORT not defined!
-- ZSTD_VERSION (bundled) is 1.5.0
-- OPENSSL_INCLUDE_DIR = /usr/include
-- OPENSSL_LIBRARY = /usr/lib64/
-- CRYPTO_LIBRARY = /usr/lib64/
-- Looking for SHA512_DIGEST_LENGTH
-- Looking for SHA512_DIGEST_LENGTH - found
Cannot find appropriate system libraries for WITH_SSL=system.
Make sure you have specified a supported SSL version.
Valid options are :
system (use the OS openssl library),
yes (synonym for system),

CMake Error at cmake/ssl.cmake:61 (MESSAGE):
  Please install the appropriate openssl developer package.

Call Stack (most recent call first):
  cmake/ssl.cmake:319 (FATAL_SSL_NOT_FOUND_ERROR)
  CMakeLists.txt:1651 (MYSQL_CHECK_SSL)

-- Configuring incomplete, errors occurred!

Is the latest Xtrabackup not compatible with OpenSSL 3.xx? I also tried compiling with -DWITH_SSL=yes or -DWITH_SSL=/usr and still the same issue.

1 Like

Did you verify that you have the libssl-dev packages installed?

1 Like

Hi @boris
We are aware of this issue and it will be fixed for next release

1 Like

Perfect, thank you :slight_smile:

1 Like