Compiling NDOUtils for a Nagios/Centreon Install

I am trying to install Nagios/Centreon on a CentOS 6.6 server and everything has compiled and configured except for NDOUTILS (tried 1.5.2 and 2.0.0), which yields an apparently-common message:

./configure --prefix=/usr/local/nagios/ --with-mysql=/usr/lib/mysql --enable-mysql --with-ndo2db-user=nagios --with-ndo2db-group=nagios

(I have also tried --with-mysql=/usr/lib64/mysql)

Gets me:

*** MySQL library could not be located… **************************

You chose to compile NDOutils with MySQL support, but I was unable to
locate the MySQL library on your system. If the library is
installed, use the --with-mysql-lib argument to specify the
location of the MySQL library.
installed, use the --with-mysql=DIR argument to specify the
location of the MySQL library, We assume mysql_config is in DIR/dir
NOTE: After you install the necessary libraries on your system:

  1. Make sure /etc/ld.so.conf has an entry for the directory in
    which the MySQL libraries are installed.
  2. Run ‘ldconfig’ to update the run-time linker options.
  3. Run ‘make devclean’ in the NDBXT distribution to clean out
    any old references to your previous compile.
  4. Rerun the configure script.

TIP: Try the following…
./configure --with-mysql=/usr/lib/mysql


I have the following Percona rpms installed:

Percona-Server-shared-56-5.6.21-rel70.0.el6.x86_64
percona-release-0.1-3.noarch
Percona-Server-server-56-5.6.21-rel70.0.el6.x86_64
Percona-SQL-shared-50-5.0.92-b23.89.rhel6.x86_64
Percona-Server-devel-56-5.6.21-rel70.0.el6.x86_64
Percona-Server-client-56-5.6.21-rel70.0.el6.x86_64

and (rightly or wrongly), these:

php-mysqlnd-5.5.18-1.el6.remi.x86_64
rsyslog-mysql-5.8.10-9.el6_6.x86_64
libdbi-dbd-mysql-0.8.3-5.1.el6.x86_64
mysql-libs-5.1.73-3.el6_5.x86_64

/usr/lib/mysql has the following in it:

ls -l
total 7384
lrwxrwxrwx. 1 root root 26 Nov 10 10:29 libmysqlclient_r.so.16 -> libmysqlclient_r.so.16.0.0
-rwxr-xr-x. 1 root root 1595240 Feb 12 2014 libmysqlclient_r.so.16.0.0
lrwxrwxrwx. 1 root root 24 Nov 10 10:29 libmysqlclient.so.16 -> libmysqlclient.so.16.0.0
-rwxr-xr-x. 1 root root 1584680 Feb 12 2014 libmysqlclient.so.16.0.0
-rw-r–r--. 1 root root 6550 Oct 21 11:27 libmysqlservices.a
-rw-r–r--. 1 root root 4363346 Oct 21 11:27 libperconaserverclient.a
lrwxrwxrwx. 1 root root 24 Nov 10 17:26 libperconaserverclient_r.a -> libperconaserverclient.a
drwxr-xr-x. 3 root root 4096 Nov 10 10:51 plugin

Server is running:

Linux uk-ess-server1 2.6.32-504.el6.x86_64 #1 SMP Wed Oct 15 04:27:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

CentOS release 6.6 (Final)

I’d appreciate any wisdom on this.

Thanks

It’s always the way…Just sorted…

yum remove Percona-SQL-shared-compat
yum remove Percona-SQL-shared-50
yum install Percona-Server-shared-compat

Configure now works.

Leaving this here for other lost souls.