Check for deprecated '.<table>' syntax used in routines. (error check prior to mysql upgrade to v8)

I’m running the utility checker in preparation to mysql upgrade to v8.

The log is generating below error message and seems to be a show stopper to upgrade. The SP that it’s complaining is just a select/group statement. I tried to rewrite the query to specifically put an table alias and still not able to work on.

Can you please advise on what it causes the issue? TIA!

Error: The following routines contain identifiers in deprecated identifier
syntax (“.

”), and should be corrected before upgrade:

Please review and check your SP to see if some deprecated identifier, like the $ sign, is being used without a quote.

Beginning with MySQL 8.0.32, use of the dollar sign as the first character in the unquoted name of a database, table, view, column, stored program, or alias is deprecated and produces a warning. This includes such names used with qualifiers (see Section 9.2.2, “Identifier Qualifiers”). The dollar sign can still be used as the leading character of such an identifier when it is quoted according to the rules given later in this section.

More Info :

Thanks Abhinav on your respond.

I’ve seen that ‘$’ sign generating when running checker to mysql v8. The SP that checker complaining does not have any ‘$’. I even revised the SP with proper aliasing on the selected columns as well as tables included on the join statement. It’s a 2 tables join, pretty straight forward and yet still erroring out during upgrade check.

Below is the screenshot of the error: