character set warning in logs

I am using PXC 5.6 (Percona-XtraDB-Cluster-56-5.6.41-28.28.1.el7.x86_64) and my log file is flooded with this warning:

[Warning] Client failed to provide its character set. ‘latin1’ will be used as client character set.

how can I disable this warning?

Hello jazikh it looks as though this is related to a MySQL bug, here is one discussion https://www.percona.com/forums/questions-discussions/mysql-and-percona-server/13590-character-set-warning

Here is the bug report: https://bugs.mysql.com/bug.php?id=72543

A poster on StackOverflow reported that after updating the connector the issue was resolved, might this apply here? https://stackoverflow.com/questions/19915443/how-to-disable-warning-for-mysql-5-6-14-on-windows-server-2012

Are you using HAProxy as well? You may find this report interesting: https://bugs.launchpad.net/percona-server/+bug/1335788

Actually, no. We are not using haproxy. Only using keepalived. We have 3 nodes cluster and using single node for read and write.