Can't create a new thread (errno 11)


In web site made on drupal + mysql. I have roughtly this error :

“Can’t create a new thread (errno 11); if you are not out of available memory, you can consult the manual for a possible OS-dependent bug”

What is the solution of the problem?

FYI : MySQL version 5.0.67
and Drupal 6.X

for information, I use 1Go of RAM this database and this the configuration fro about more tant 1000 user on website:



key_buffer_size = 64M
max_allowed_packet = 64M
table_cache = 5000
myisam_sort_buffer_size = 64M
sort_buffer_size = 16M
join_buffer_size = 8M
read_buffer_size = 8M
read_rnd_buffer_size = 4M
net_buffer_length = 2K
thread_stack = 256K

max_binlog_cache_size = 1M
max_join_size = 24M
max_seeks_for_key = 2M
max_write_lock_count = 512K
myisam_max_sort_file_size = 4M

interactive_timeout = 25
wait_timeout = 300
connect_timeout = 10
max_connect_errors = 3000

#if you get a long query selecting a lot of data you might want to increase this
query_cache_limit = 32M
query_cache_type = 1

##Configuration Innodb##
##Uncomment the next line to disable Innodb


innodb_buffer_pool_size = 32M
innodb_additional_mem_pool_size = 8M

innodb_log_file_size = 10M
innodb_log_buffer_size = 4M


Please help me.

The ‘perror’ utility installed with MySQL will tell you the meaning of an error code. In this case,

[baron@ginger ~]$ perror 11
OS error code 11: Resource temporarily unavailable

The error probably means what the error message from MySQL says: you are out of memory. Your configuration looks very bad. Just comment out the following:

sort_buffer_size = 16M
join_buffer_size = 8M
read_buffer_size = 8M
read_rnd_buffer_size = 4M

Those can easily be the cause of your problem. Leave those at their defaults until you are an expert and you can prove they need to be tuned ) But at the same time, other things might be happening on the server that are consuming memory. So maybe it is the combination of a few queries using a bunch of memory, and a backup job, or something else like that.

Finally, if you are using InnoDB your configuration is almost certainly not right for more than a few MB of data.