Cannot determine the xtrabackup version. Needs xtrabackup-2.4.20 or higher to perform SST

Hi all -

I’m trying to run a cluster on Kubernetes using 3 pxc and 3 haproxy nodes. I’m using version 5.7 of the MySQL containers. The first container spins up fine and works as expected. As soon as a second container spins up, I get the error in the subject line. I have been able to spin up multi-node clusters using version 8 with no issues. I have tried this on a TKGI and Docker Desktop Kubernetes environments with the same results.

percona log.txt

I’ve attached the log for review, but I can’t seem to determine why a second node fails, but not the first. Please let me know if there is any other information I can provide for help.

Thank you!

percona log.txt (19.6 KB)

1 Like

Hi rlanner,

Could you please share with us the operators version and CR.yaml ?

1 Like

Hi Ivan,

Here is the cr.yaml I am using. The versions of the images are included in the yaml and I am pointing to an internal repository that I pushed these images to from docker hub.

cr-tst.zip

If possible, could your team add the ability to upload yaml files? That extension is blocked so I zipped it.

Thanks!

1 Like

Hi rtanner,

We are able to reproduce this bug. Thus we are going to discuss such an issue with our developers.
Please, stay in touch.

1 Like

Thank you. Please don’t hesitate to let me know how I can help.

Thanks again!

(www.blackberry.com)

1 Like

Hi @rtanner

After some additional investigation we’ve come across the configuration option which triggered the error you faced.
Xtrabackup utility compatible with 5.7 is not capable to work with lz4 compression. It was introduced for 8.0 version only. We recommend you to switch from lz to another supported compression type.

1 Like