Cannot create users on a fresh deployment of percona operator and percona server via helm


hope this is the right place to ask. I’m currently trying to setup a Percona Server async cluster via Percona Operator on AWS EKS. Installation seems to work fine, kubectl get ps -n percona shows the cluster running in a healthy state. I can connect via the created root user and create databases and tables, but adding application users fails.

GRANT ALL PRIVILEGES ON . to ‘app1’@‘%’ IDENTIFIED BY ‘abcdefg’;
returns ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘IDENTIFIED BY ‘abcdefg’’ at line 1

CREATE USER ‘app1’@‘%’ IDENTIFIED WITH caching_sha2_password BY ‘abcdefg’;
fails with ERROR 1227 (42000): Access denied; you need (at least one of) the SYSTEM_USER privilege(s) for this operation

Could you please point me on what I’m missing out?

Best thanks!

1 Like

Hi again,

Problem solved. Seems it was caused by some former helm-install with standard credentials being left after uninstall. Deleting and recreating the namespace worked, now root can create users. Still somehow strange and in my opinion a bug, since the new root password from the secret worked for login but not for grants.

1 Like