Can not get Percona XtraDB Cluster to link up, start mysql, its a cluster f...

Ok guys,

I have tried the following five tutorials, mixed and matched, spent the past two days, over 30 hours trying to get this to work. I have spun up and down amazon ec2 instance after instance. Are these tutorials up to date? Is it possible they are missing something? I truly don’t see how I could get all of these tutorials wrong after starting from scratch so many times…

Seriously, I need someone to try and get a 3 cluster node working on AWS EC2 using CentOS 6.3 ( because I do not think it is possible, and I am literally pulling my hair out… I see all these good people running Percona, and I am like what the hell over here…

I have made sure selinux is disabled, I blantently have turned iptables off, added firewall rules for the security group, I can ssh to 4567, however, mysql doesn’t want to start on any of the clusters, except right after a reboot on the first node, using mysqld_safe … Also, mysqld_safe seems to be the only way I get any feedback from the app, otherwise, it just says Starting…ERROR with nothing in the logs…

Please Please Please, will someone attempt a 3 node cluster using the above ami, and tell me if I am crazy or not…

btw here are the links I followed that I mentioned earlier…
[LIST]
[][URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/cenots_howto.html”]Installing Percona XtraDB Cluster on CentOS[/URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/cenots_howto.html”]
[
][URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/singlebox.html”]How to setup 3 node cluster on single box[/URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/singlebox.html”]
[][URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/3nodesec2.html”]How to setup 3 node cluster in EC2 enviroment[/URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/3nodesec2.html”]
[
][URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/haproxy.html”]Load balancing with HAProxy[/URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/haproxy.html”]
[*][URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/virt_sandbox.html”]Setting up PXC reference architecture with HAProxy[/URL=“http://www.percona.com/doc/percona-xtradb-cluster/howtos/virt_sandbox.html”]
[/LIST]

Greetings,

You know i have set up this same setup using the same guides you have 20 times or so for customers, I was like hmm let me give this a shot yet again. The only difference is I am using the Rackspace Cloud. I am seeing the same issue I have fought with this for over 40 hours this past weekend. This is what i came up with as it is failing for me as well. I see it running but no /usr/bin/xtrabackup_55 is being called on the donor, on the donor:

[root@percona1 mysql]# which xtrabackup_55
/usr/bin/xtrabackup_55

As well i see that NC is running on both servers but no data is being transferred, in this state, well I am leaning towards this being a bug in xtrabackup 2.1.2. I hope that the devs or someone can chime in and give us some ideal on what happened this was working 2 weeks ago now its broke.

Thanks,

Will McInnis

I fixed it! kinda!

If you followed the instructions it will installed 2.1.2! something in this version is bad!!! not sure yet, so to get mine to work here is what i did:

Make sure that the master or node1 is STOPPED!!!

wget repo.percona.com/centos/6/os/x86_64/percona-xtrabackup-2.0.7-552.rhel6.x86_64.rpm
wget repo.percona.com/centos/6/os/x86_64/Percona-XtraDB-Cluster-server-5.5.30-23.7.4.406.rhel6.x86_64.rpm
yum remove percona-xtrabackup #THIS will remove the cluster we software that is ok!
rpm -ihv percona-xtrabackup-2.0.7-552.rhel6.x86_64.rpm
rpm -ihv Percona-XtraDB-Cluster-server-5.5.30-23.7.4.406.rhel6.x86_64.rpm
/etc/init.d/mysql start --wsrep-cluster-address="gcomm://"

If you have problems feel free to email me:

will.mcinnis at rackspace.com

As well you might want to disable the percona repo until this is fixed.

HAPPY DANCE!

attachment