Anyone testing XtraDB cluster 8?

Hi all,

I thought I’d give an experimental tarball a shot, although I’ve done so on 3 CentOS 8 VMs (so far the only requirements difference was having to install compat-openssl10). So I extracted the tarball, created an /etc/my.cnf with a set of options to allow bootstrapping the first node. The issues I’ve encountered so far and could use some feedback on:

  • On MySQL startup: “[Server] unknown variable 'wsrep_sst_auth=”, so I comment this option in my.cnf
    However, I’m unable to find references to this option begin deprecated and some other taking its place.

  • Joining a node to expand the cluster.
    On starting up the second node I get an error message

2019-11-11T18:47:25.956452Z 0 [ERROR] [MY-000000] [WSREP-SST] ******************* FATAL ERROR **********************
2019-11-11T18:47:25.957360Z 0 [ERROR] [MY-000000] [WSREP-SST] The xtrabackup version is .
2019-11-11T18:47:25.957427Z 0 [ERROR] [MY-000000] [WSREP-SST] xtrabackup-2.4.13 or higher is needed to perform an SST
2019-11-11T18:47:25.957459Z 0 [ERROR] [MY-000000] [WSREP-SST] /usr/local/percona-xtradb-cluster-8/bin/pxc_extra/pxb-2.4/bin/xtrabackup
2019-11-11T18:47:25.957486Z 0 [ERROR] [MY-000000] [WSREP-SST] ******************************************************
2019-11-11T18:47:25.957893Z 0 [ERROR] [MY-000000] [WSREP] Process completed with error: wsrep_sst_xtrabackup-v2 --role ‘joiner’ --address ‘’ --datadir ‘/var/lib/mysql/’ --basedir ‘/usr/local/percona-xtradb-cluster-8/’ --plugindir ‘/usr/local/percona-xtradb-cluster-8/lib/mysql/plugin/’ --defaults-file ‘/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘11016’ --mysqld-version ‘8.0.15-5-27dev.4.2’ --binlog ‘/var/lib/mysql/percona_binlog’ : 2 (No such file or directory)
2019-11-11T18:47:25.958427Z 2 [ERROR] [MY-000000] [WSREP] Failed to prepare for ‘xtrabackup-v2’ SST. Unrecoverable.
2019-11-11T18:47:25.958654Z 2 [ERROR] [MY-010119] [Server] Aborting

after which MySQL crashes.
Admittedly, I’m starting MySQL on the command line, thus probably omitting environment variables MySQL may depend on (as well as xtrabackup for that matter), because I’ve only ever set up a cluster from a binary and sure could use directions on how to overcome these few issues.


The sst user for this cluster is not internally generated and manager within the cluster so that parameter is no longer used/relevant. PXC creates a one time password. for each SST.
I think you need extrabackup 8 for mysql 8 so maybe an older rpm is on there.
Also --no-version-check is an option for xtrabackup

Makes sense.

Yes, I think I read somewhere only Xtrabackup 8 will work with XtraDB cluster 8, and both mysqldump and rsync and deprecated… but it’s proven tricky to find a way to force the cluster to use v8, and I’m a bit tired of trial-and-error with trying to fool the cluster. Thus, even ‘wsrep_sst_method’ should be deprecated, but it doesn’t seem to be.
On top of that:

  • Setting the wsrep_sst_method to either of: xtrabackup-v2, xtrabackup, xtrabackup-v8, or xtrabackup-v80 doesn’t help
  • The error message in the example above was triggered in one particular case when wsrep_sst_method was either absent or set to xtrabackup-v2, and still
    the cluster found the xtrabckup binary in /usr/local/percona-xtradb-cluster-8/bin/pxc_extra/pxb-2.4/bin/xtrabackup, although there’s a /usr/local/percona-xtradb-cluster-8/bin/pxc_extra/pxb-8.0/bin/xtrabackup. I tried renaming the former and linking the latter with a link name pxb-8.0 to no avail.
    Also, I tried installing and RPM of xtrabackup 8, still no dice.