I’m trying to enable ALLOW_INVALID_DATES in both the config and the live GLOBAL setting at the mysql command line. When i check the configuration using SELECT @@sql_mode;
it shows that it’s enabled, but it still throughs an error while trying to execute the query.

If there another way to do this in Percona Cluster 8?

Hi @Ken_Scott,
From the MySQL manual:

With ALLOW_INVALID_DATES disabled, the server requires that month and day values be legal, and not merely in the range 1 to 12 and 1 to 31, respectively. With strict mode disabled, invalid dates such as '2004-04-31' are converted to '0000-00-00' and a warning is generated.

You need to also disable STRICT_TRANS_TABLES.


Yes I understand, however I’m trying to enable ALLOW_INVALID_DATES and it’s not working, it still required date not to be null.

Please provide examples of what you are trying to accomplish, along with an example of the failure.