1.12.0, crd.yaml nok


I am getting this error when executing

kubectl -n not-necessary apply -f https://raw.githubusercontent.com/percona/percona-server-mongodb-operator/v1.12.0/deploy/crd.yaml

customresourcedefinition.apiextensions.k8s.io/perconaservermongodbbackups.psmdb.percona.com configured
customresourcedefinition.apiextensions.k8s.io/perconaservermongodbrestores.psmdb.percona.com configured
The CustomResourceDefinition "perconaservermongodbs.psmdb.percona.com" is invalid: spec.preserveUnknownFields: Invalid value: true: must be false in order to use defaults in the schema

I have a funny it worked a couple of weeks ago ?!


1 Like

Hi @jamoser, We need to know more about your deployment. Do you try to update your CRD or deploy new cluster?

Hi @Slava_Sarzhan

I have deployed up to version 1.11.0 previously and then updated to 1.12.0 (a few months after 1.12.0 got released.

On DEV env I did exactly the same right after 1.12.0 got released by Percona - there it worked flawlessly. Could it be that you updated the 1.12.0 branch since the release ?

Hi @jamoser
We have added this fix https://github.com/percona/percona-xtradb-cluster-operator/commit/1f650c5088bc323ba2d43d9d6b7d958be786662c into 1.12.0 but we did not move tag. So, it was in 1.12.0 from the very beginning.