Failed State Transfer

Hi there,

I’ve been trying to setup a Percona Cluster but have so far gotten to one part and I can’t get past.

Setup:
I used binary installs, yum installs and a mix of the two and always get the same problem. My current setup is a Binary only install. It is different than the documentation I know.

PC 1: 10.0.0.11 (as example) CentOS 7.1

  • Percona-XtraDB-Cluster-5.6.28-rel76.1-25.14.1.Linux.x86_64.ssl101.tar.gz
  • percona-xtrabackup-2.3.3-Linux-x86_64.tar.gz
  • Users: root, mysql
  • DB Users: root@localhost, root@10.0.0.11, sstuser@localhost, sstuser@10.0.0.22
    PC 2: 10.0.0.22 (as example) CentOS 7.1
  • Percona-XtraDB-Cluster-5.6.28-rel76.1-25.14.1.Linux.x86_64.ssl101.tar.gz
  • percona-xtrabackup-2.3.3-Linux-x86_64.tar.gz
  • Users: root, mysql
  • DB Users: N/A

PC 1 - my.cnf
[mysqld]
basedir=/opt/current/percona
datadir=/opt/current/percona/data
socket=/tmp/mysql.sock

Disabling symbolic-links is recommended to prevent assorted security risks

symbolic-links=0

Settings user and group are ignored when systemd is used.

If you need to run mysqld under a different user or group,

customize your systemd unit file for mariadb according to the

instructions in http://fedoraproject.org/wiki/Systemd

Settings

wsrep_provider=/opt/current/percona/lib/libgalera_smm.so
wsrep_cluster_address=gcomm://
wsrep_slave_threads=8
wsrep_node_address=10.0.0.11
wsrep_node_name=master1
wsrep_sst_method=xtrabackup-v2
wsrep_cluster_name=percona_test
wsrep_sst_auth=“sstuser:s3cret”
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2
pid_file=/opt/current/percona/socket/mysql.pid
user=mysql
server-id=1

[mysqld_safe]
log-error=/opt/current/percona/log/percona.log
pid-file=/opt/current/percona/socket/mysql.pid

include all files from the config directory

!includedir /etc/my.cnf.d

Starts and works when bootstrapped with:

service mysql bootstrap-pxc

PC 2 - my.cnf
[mysqld]
basedir=/opt/current/percona
datadir=/opt/current/percona/data
socket=/tmp/mysql.sock

Disabling symbolic-links is recommended to prevent assorted security risks

symbolic-links=0

Settings user and group are ignored when systemd is used.

If you need to run mysqld under a different user or group,

customize your systemd unit file for mariadb according to the

instructions in http://fedoraproject.org/wiki/Systemd

Settings

wsrep_provider=/opt/current/percona/lib/libgalera_smm.so
wsrep_cluster_address=gcomm://10.0.0.11,10.0.0.22
wsrep_slave_threads=8
wsrep_node_address=10.0.0.22
wsrep_node_name=slave1
wsrep_sst_method=xtrabackup-v2
wsrep_cluster_name=percona_test
wsrep_sst_auth=“sstuser:s3cret”
binlog_format=ROW
default_storage_engine=InnoDB
innodb_autoinc_lock_mode=2
pid_file=/opt/current/percona/socket/mysql.pid
user=mysql
server-id=1

[mysqld_safe]
log-error=/opt/current/percona/log/percona.log
pid-file=/opt/current/percona/socket/mysql.pid

include all files from the config directory

!includedir /etc/my.cnf.d

However when I try to start it with mysqld start I get a error about State Transfer failing.

http://pastebin.com/raw/ZBFtxsrV

Does anyone know what I can do to fix this “as is”. Meaning I’d like to keep the setup as I’ve done it. I have the variables MYSQL_HOME setup on both and xtrabackup is in the PATH variable of the mysql user on 10.0.0.22. SOCAT, NC and RSYNC are installed and selinux is disabled.

have you tried leaving variable “wsrep_cluster_address=” with blanks instead of defining IP on joining node?