Added 4 MySQL servers as clients but the PMM Metrics Monitor only shows one

Hi All, I ha ve 5 servers in total:

  1. Used for pmm-server, installed with Docker
  2. MySQL master server for DB1
  3. MySQL slave server for DB1 (Maria DB)
  4. MySQL slave server for DB1 (Maria DB)
  5. MySQL master server for DB2

I installed the pmm-client on all 4 servers (2-5) but on the graph/dashboard/db/cross-server-graphs?refresh=1m&orgId=1 url, I can only see the metrics for the pmm-server and the server number 2 hosting the DB1 master DB.

Any idea on what I am doing wrong? Should I open some ports on other servers (firewall)? Is there something to do in MySQL settings, on the Pmm server side?
Note that the port used is 8077 for the master.

On all 4 MySQL servers, I can see while executing sudo pmm-admin list:

  1. pmm-admin 1.7.0

PMM Server | aaa.aaa.aaa.aaa::8077
Client Name | MySQL
Client Address | bbb.bbb.bbb.bbb
Service Manager | linux-upstart


SERVICE TYPE NAME LOCAL PORT RUNNING DATA SOURCE OPTIONS


mysql:queries MySQL - YES root:@unix(/var/run/mysqld/mysqld.sock) query_source=slowlog, query_examples=true
linux:metrics MySQL 42000 YES -
mysql:metrics MySQL 42002 YES root:
@unix(/var/run/mysqld/mysqld.sock) tablestats=OFF

  1. pmm-admin 1.7.0

PMM Server | aaa.aaa.aaa.aaa::8077
Client Name | mysql3
Client Address | ccc.ccc.ccc.ccc
Service Manager | linux-systemd


SERVICE TYPE NAME LOCAL PORT RUNNING DATA SOURCE OPTIONS


mysql:queries mysql3 - YES root:@unix(/var/run/mysqld/mysqld.sock) query_source=slowlog, query_examples=true
linux:metrics mysql3 42000 YES -
mysql:metrics mysql3 42002 YES root:
@unix(/var/run/mysqld/mysqld.sock) tablestats=OFF

  1. pmm-admin 1.7.0

PMM Server | aaa.aaa.aaa.aaa:8077
Client Name | mysql2
Client Address | ddd.ddd.ddd.ddd
Service Manager | linux-systemd


SERVICE TYPE NAME LOCAL PORT RUNNING DATA SOURCE OPTIONS


mysql:queries mysql2 - YES root:@unix(/var/run/mysqld/mysqld.sock) query_source=slowlog, query_examples=true
linux:metrics mysql2 42000 YES -
mysql:metrics mysql2 42002 YES root:
@unix(/var/run/mysqld/mysqld.sock) tablestats=OFF

  1. pmm-admin 1.7.0

PMM Server | aaa.aaa.aaa.aaa::8077
Client Name | chbslds018
Client Address | eee.eee.eee.eee
Service Manager | linux-upstart


SERVICE TYPE NAME LOCAL PORT RUNNING DATA SOURCE OPTIONS


mysql:queries chbslds018 - YES root:@unix(/var/run/mysqld/mysqld.sock) query_source=slowlog, query_examples=true
linux:metrics chbslds018 42000 YES -
mysql:metrics chbslds018 42002 YES root:
@unix(/var/run/mysqld/mysqld.sock)

Thank you!

Solved by checking the network status with: sudo pmm-admin check-network
The connection Connection: Client <-- Server was down. I had to open the port 42000 for the pmm-server on pmm-clients.
Since, all is ok.

Ah excellent - thanks for the update, Milos, it might helps someone else in the future.

Would be a good idea to also mention the firewall on the “Deploying Percona Monitoring and Management” documentation, or I maybe missed this info :slight_smile:

Hi Milos , I am glad you were able to solve this, and yes I agree our Documentation is missing this important reference - the firewall mention is buried in our Glossary in the Ports section https://www.percona.com/doc/percona-monitoring-and-management/glossary.terminology.html. I’ve submitted a ticket to improve Doc, thanks for reporting it!
https://jira.percona.com/browse/PMM-2099