# Yum update error after installing Percona Release

**URL:** <https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108>\
**Category:** Percona XtraDB Cluster 8.x\
**Created:** [October 20, 2022, 9:40am UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108 "2022-10-20T09:40:05Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![MikeBerry](https://avatars.discourse-cdn.com/v4/letter/m/b3f665/32.png) [@MikeBerry](https://forums.percona.com/u/MikeBerry)\
**Post date:** [October 20, 2022, 9:40am UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108/1 "2022-10-20T09:40:05Z")

</div>

Hi

Basic Centos7 install. Yum update works fine.

* * *

Then I installed the percona release.  
[root@prod-mysql-lb2 centos]# yum install [https://repo.percona.com/yum/percona-release-latest.noarch.rpm](https://repo.percona.com/yum/percona-release-latest.noarch.rpm) -y  
Loaded plugins: fastestmirror  
percona-release-latest.noarch.rpm | 20 kB 00:00:00  
Examining /var/tmp/yum-root-hcGcso/percona-release-latest.noarch.rpm: percona-release-1.0-27.noarch  
Marking /var/tmp/yum-root-hcGcso/percona-release-latest.noarch.rpm to be installed  
Resolving Dependencies  
 → Running transaction check  
—\> Package percona-release.noarch 0:1.0-27 will be installed  
 → Finished Dependency Resolution

Dependencies Resolved

# =============================================================================================================================================================================================================== Package Arch Version Repository Size

Installing:  
percona-release noarch 1.0-27 /percona-release-latest.noarch 32 k

# Transaction Summary

Install 1 Package

Total size: 32 k  
Installed size: 32 k  
Downloading packages:  
Running transaction check  
Running transaction test  
Transaction test succeeded  
Running transaction  
Installing : percona-release-1.0-27.noarch 1/1

- Enabling the Percona Original repository  
\<\*\> All done!
- Enabling the Percona Release repository  
\<\*\> All done!  
The percona-release package now contains a percona-release script that can enable additional repositories for our newer products.

For example, to enable the Percona Server 8.0 repository use:

percona-release setup ps80

Note: To avoid conflicts with older product versions, the percona-release setup command may disable our original repository for some products.

For more information, please visit:  
[Percona Documentation](https://www.percona.com/doc/percona-repo-config/percona-release.html)

Verifying : percona-release-1.0-27.noarch 1/1

Installed:  
percona-release.noarch 0:1.0-27

Complete!

* * *

Then the yum update fails with errors  
[root@prod-mysql-lb2 centos]# yum update -y  
Loaded plugins: fastestmirror  
Loading mirror speeds from cached hostfile

- base: [mirrors.vinters.com](http://mirrors.vinters.com)
- epel: [fedora.mirrorservice.org](http://fedora.mirrorservice.org)
- extras: [mirrors.vinters.com](http://mirrors.vinters.com)
- updates: [ukhub.a2themes.com](http://ukhub.a2themes.com)  
percona-release-noarch | 1.5 kB 00:00:00  
percona-release-x86\_64 | 2.9 kB 00:00:00  
prel-release-noarch | 1.5 kB 00:00:00  
(1/3): prel-release-noarch/7/primary | 1.2 kB 00:00:00  
(2/3): percona-release-noarch/7/primary | 9.0 kB 00:00:00  
(3/3): percona-release-x86\_64/7/primary\_db | 1.3 MB 00:00:00  
percona-release-noarch 65/65  
prel-release-noarch 5/5  
Resolving Dependencies  
 → Running transaction check  
—\> Package Percona-Server-shared-55.x86\_64 0:5.5.62-rel38.14.el7 will be obsoleting  
—\> Package Percona-Server-shared-56.x86\_64 0:5.6.51-rel91.0.1.el7 will be obsoleting  
—\> Package Percona-Server-shared-compat-57.x86\_64 0:5.7.39-42.1.el7 will be obsoleting  
—\> Package Percona-XtraDB-Cluster-shared-55.x86\_64 1:5.5.41-25.12.855.el7 will be obsoleting  
—\> Package Percona-XtraDB-Cluster-shared-56.x86\_64 1:5.6.51-28.46.1.el7 will be obsoleting  
—\> Package Percona-XtraDB-Cluster-shared-57.x86\_64 0:5.7.39-31.61.1.el7 will be obsoleting  
—\> Package Percona-XtraDB-Cluster-shared-compat-57.x86\_64 0:5.7.39-31.61.1.el7 will be obsoleting  
—\> Package mariadb-libs.x86\_64 1:5.5.68-1.el7 will be obsoleted  
 → Processing Conflict: Percona-XtraDB-Cluster-shared-57-5.7.39-31.61.1.el7.x86\_64 conflicts Percona-Server-shared-56  
 → Processing Conflict: 1:Percona-XtraDB-Cluster-shared-55-5.5.41-25.12.855.el7.x86\_64 conflicts Percona-Server-shared-55  
 → Processing Conflict: 1:Percona-XtraDB-Cluster-shared-55-5.5.41-25.12.855.el7.x86\_64 conflicts Percona-XtraDB-Cluster-shared-56  
 → Processing Conflict: 1:Percona-XtraDB-Cluster-shared-56-5.6.51-28.46.1.el7.x86\_64 conflicts Percona-Server-shared-56  
 → Processing Conflict: Percona-Server-shared-55-5.5.62-rel38.14.el7.x86\_64 conflicts Percona-Server-shared-56  
 → Processing Conflict: Percona-XtraDB-Cluster-shared-compat-57-5.7.39-31.61.1.el7.x86\_64 conflicts Percona-XtraDB-Cluster-shared-55  
 → Processing Conflict: Percona-XtraDB-Cluster-shared-compat-57-5.7.39-31.61.1.el7.x86\_64 conflicts Percona-XtraDB-Cluster-shared-56  
 → Processing Conflict: Percona-Server-shared-56-5.6.51-rel91.0.1.el7.x86\_64 conflicts Percona-Server-shared-55  
 → Processing Conflict: Percona-Server-shared-compat-57-5.7.39-42.1.el7.x86\_64 conflicts Percona-Server-shared-55  
 → Processing Conflict: Percona-Server-shared-compat-57-5.7.39-42.1.el7.x86\_64 conflicts Percona-Server-shared-56  
 → Finished Dependency Resolution  
Error: Percona-Server-shared-compat-57 conflicts with Percona-Server-shared-56-5.6.51-rel91.0.1.el7.x86\_64  
Error: Percona-XtraDB-Cluster-shared-56 conflicts with Percona-Server-shared-56-5.6.51-rel91.0.1.el7.x86\_64  
Error: Percona-XtraDB-Cluster-shared-57 conflicts with Percona-Server-shared-56-5.6.51-rel91.0.1.el7.x86\_64  
Error: Percona-XtraDB-Cluster-shared-55 conflicts with 1:Percona-XtraDB-Cluster-shared-56-5.6.51-28.46.1.el7.x86\_64  
Error: Percona-Server-shared-56 conflicts with Percona-Server-shared-55-5.5.62-rel38.14.el7.x86\_64  
Error: Percona-XtraDB-Cluster-shared-compat-57 conflicts with 1:Percona-XtraDB-Cluster-shared-56-5.6.51-28.46.1.el7.x86\_64  
Error: Percona-Server-shared-55 conflicts with Percona-Server-shared-56-5.6.51-rel91.0.1.el7.x86\_64  
Error: Percona-XtraDB-Cluster-shared-55 conflicts with Percona-Server-shared-55-5.5.62-rel38.14.el7.x86\_64  
Error: Percona-Server-shared-compat-57 conflicts with Percona-Server-shared-55-5.5.62-rel38.14.el7.x86\_64  
Error: Percona-XtraDB-Cluster-shared-compat-57 conflicts with 1:Percona-XtraDB-Cluster-shared-55-5.5.41-25.12.855.el7.x86\_64  
You could try using --skip-broken to work around the problem  
You could try running: rpm -Va --nofiles --nodigest

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [October 20, 2022, 1:43pm UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108/2 "2022-10-20T13:43:56Z")

</div>

Hello @MikeBerry,  
Major releases of PS MySQL will conflict. This is done intentionally to prevent accidental upgrades between major releases. Historically, each major release includes breaking changes against the previous version. If you want to upgrade from PS55 to PS56, you must first uninstall PS55.

---

<div class="post-metadata">

**Author:** ![MikeBerry](https://avatars.discourse-cdn.com/v4/letter/m/b3f665/32.png) [@MikeBerry](https://forums.percona.com/u/MikeBerry)\
**Post date:** [October 20, 2022, 3:18pm UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108/3 "2022-10-20T15:18:09Z")

</div>

Hi matthew

This vm is going to be the load balancer with proxysql installed. I have tried installing proxysql and percona xtradb client but I get the update errors. I have also tried not installing any of the percona or proxysql products but I still get the same error. I get this update error after installing the percona release. Sorry if my knowledge is lacking but I thought this was the repo so that I could then install percona packages so I am a bit baffled why when I don’t have any percona packages installed that I get a yum update error.  
[root@prod-mysql-lb2 centos]# yum list installed | grep percona\*  
percona-release.noarch 1.0-27 @/percona-release-latest.noarch

I have 3 clusters with percona xtradb after installing the same way and they don’t get this yum update error, but they do have all the percona 8.0 packages installed.  
[root@prod-mysql-c2 mysql]# yum list installed | grep percona\*  
percona-release.noarch 1.0-27 @/percona-release-latest.noarch  
percona-toolkit.x86\_64 3.4.0-3.el7 @percona-release-x86\_64  
percona-xtrabackup-80.x86\_64 8.0.29-22.1.el7 @percona-release-x86\_64  
percona-xtradb-cluster.x86\_64 8.0.29-21.1.el7 @pxc-80-release-x86\_64  
percona-xtradb-cluster-client.x86\_64 8.0.29-21.1.el7 @pxc-80-release-x86\_64  
percona-xtradb-cluster-server.x86\_64 8.0.29-21.1.el7 @pxc-80-release-x86\_64  
percona-xtradb-cluster-shared.x86\_64 8.0.29-21.1.el7 @pxc-80-release-x86\_64  
percona-xtradb-cluster-shared-compat.x86\_64  
pmm2-client.x86\_64 2.31.0-6.el7 @percona-release-x86\_64  
qpress.x86\_64 11-3.el7 @percona-release-x86\_64

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [October 20, 2022, 5:16pm UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108/4 "2022-10-20T17:16:48Z")

</div>

Hi Mike,  
The output after you install our repo package says you need to configure it. Run:

```
percona-release setup proxysql

```

Then you should be able to `yum install proxysql2`

---

<div class="post-metadata">

**Author:** ![Evgeniy\_Patlan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/evgeniy_patlan/32/41_2.png) [@Evgeniy\_Patlan](https://forums.percona.com/u/Evgeniy_Patlan)\
**Post date:** [October 21, 2022, 8:38am UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108/5 "2022-10-21T08:38:27Z")

</div>

In this case you can disable percona repo  
percona-release disable percona release  
after that you can enable tools or as @matthewb mentioned proxysql repo  
percona-release enable tools release  
or  
percona-release enable proxysql release

---

<div class="post-metadata">

**Author:** ![MikeBerry](https://avatars.discourse-cdn.com/v4/letter/m/b3f665/32.png) [@MikeBerry](https://forums.percona.com/u/MikeBerry)\
**Post date:** [October 31, 2022, 3:12pm UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108/6 "2022-10-31T15:12:10Z")

</div>

I must not be explaining myself correctly so I will try again…

* * *

I can install proxysql just fine using the proxy repo below. I don’t need percona repo for that.  
[proxysql\_repo]  
name=ProxySQL YUM repository  
baseurl=[Index of /ProxySQL/proxysql-2.4.x/centos/7/](https://repo.proxysql.com/ProxySQL/proxysql-2.4.x/centos/7)  
gpgcheck=1  
gpgkey=[https://repo.proxysql.com/ProxySQL/proxysql-2.4.x/repo\_pub\_key](https://repo.proxysql.com/ProxySQL/proxysql-2.4.x/repo_pub_key)

* * *

I can install the percona release and percona xtradb client just fine using;  
yum install [https://repo.percona.com/yum/percona-release-latest.noarch.rpm](https://repo.percona.com/yum/percona-release-latest.noarch.rpm) -y  
percona-release enable pxc-80 release  
yum install percona-xtradb-cluster-client -y  
yum update -y (FAILS)

* * *

At this point percona client works with proxysql just fine but a yum update fails. If I remove the percona release then the yum update works again. (disabling the percona release did not stop the yum update error).  
yum remove percona-release -y  
yum update -y (works fine)

* * *

Also If I re-install the percona repo and set it up again as i did with the clusters then yum update works again.  
yum install [https://repo.percona.com/yum/percona-release-latest.noarch.rpm](https://repo.percona.com/yum/percona-release-latest.noarch.rpm) -y  
percona-release enable pxc-80 release  
yum install percona-xtradb-cluster percona-xtrabackup-80 -y  
yum update -y (works fine)

* * *

So, there is obviously something wrong with the percona repo and the percona client on its own causes a yum update error!

To get past the yum update error I have installed the mysql community client instead of the percona client. Everything works including the yum update. Pity really, because I wanted the servers with percona as standard.

Lastly I thought I would try installing xtradb cluster then unistalling, and guess what, the yum update works, so after a bit of trial and error I have found that I need to install the percona shared compatible package in order for the yum update to work again.  
yum install [https://repo.percona.com/yum/percona-release-latest.noarch.rpm](https://repo.percona.com/yum/percona-release-latest.noarch.rpm) -y  
percona-release enable pxc-80 release  
yum install percona-xtradb-cluster-shared-compat -y

* * *

Now I have proxysql, percona xtradb cluster client and percona xtradb cluster shared compat installed, everything works including yup update.

So, if you want to install the percona client to use with proxysql, you have to install the percona shared compat aswell else yum update fails.  
yum install [https://repo.percona.com/yum/percona-release-latest.noarch.rpm](https://repo.percona.com/yum/percona-release-latest.noarch.rpm) -y  
percona-release enable pxc-80 release  
yum install percona-xtradb-cluster-client percona-xtradb-cluster-shared-compat -y

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [October 31, 2022, 3:40pm UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108/7 "2022-10-31T15:40:58Z")

</div>

Hello @MikeBerry,

> [@MikeBerry](#):
>
> So, there is obviously something wrong with the percona repo

We have thousands of downloads/usage of our repo daily. I myself used our repo just last Thursday to upgrade a client from MariaDB 5.5 to PS56, then PS57, and finally to Percona Server 8.0. It worked flawlessly. It is more likely that you are using our repo incorrectly than there is something wrong with our repo. If there was something truly wrong, we would see an incoming flood of support tickets asking what’s wrong. This is not the case, so let’s stop pointing the finger were we know the problem is not.

Let me reiterate something I said above, ‘yum update’ **will not** update major/minor versions of Percona Server. (yum update _will_ work on patch versions) The package conflicts errors you are seeing is because of this. This is by design. In order to upgrade from PS56 to PS57 (for example) you must first uninstall all PS56 packages. This process will _never_ be automatically done by yum. You must `yum remove' or 'rpm -e --nodeps` to remove the 56 packages, then use yum to install 57.

---

<div class="post-metadata">

**Author:** ![Evgeniy\_Patlan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/evgeniy_patlan/32/41_2.png) [@Evgeniy\_Patlan](https://forums.percona.com/u/Evgeniy_Patlan)\
**Post date:** [November 2, 2022, 10:23pm UTC](https://forums.percona.com/t/yum-update-error-after-installing-percona-release/18108/8 "2022-11-02T22:23:33Z")

</div>

please use `percona-release setup pxc-80` instead of `percona-release enable pxc-80 release` in this case all repos will be configured correctly. and it should solve the dependency issue you have
