# Yum repository seems to be broken

**URL:** <https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751>\
**Category:** Percona Server for MySQL 5.6\
**Created:** [September 18, 2014, 4:10am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751 "2014-09-18T04:10:30Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rasto\_Stric](https://avatars.discourse-cdn.com/v4/letter/r/bc79bd/32.png) [@Rasto\_Stric](https://forums.percona.com/u/Rasto_Stric)\
**Post date:** [September 18, 2014, 4:10am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/1 "2014-09-18T04:10:30Z")

</div>

I am trying to install Percona Server 5.6 on a fresh Amazon Linux AMI.  
I am following your installation instructions on [URL][http://www.percona.com/doc/percona-server/5.6/installation/yum\_repo.html[/URL]](http://www.percona.com/doc/percona-server/5.6/installation/yum_repo.html%5B/URL%5D)

```auto

yum install http://www.percona.com/downloads/percona-release/percona-release-0.0-1.x86_64.rpm

```

This finishes without problems.

But when I try

```auto

yum list | grep percona

```

or

```auto

yum install Percona-Server-client-56 Percona-Server-server-56

```

I get:

PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”  
Trying other mirror.

One of the configured repositories failed (CentOS latest - Percona),  
and yum doesn’t have enough cached data to continue. At this point the only  
safe thing yum can do is fail. There are a few ways to work “fix” this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working  
upstream. This is most often useful if you are using a newer  
distribution release than is supported by the repository (and the  
packages for the previous distribution release still work).

3. Disable the repository, so yum won’t use it by default. Yum will then  
just ignore the repository until you permanently enable it again or use  
–enablerepo for temporary usage:

yum-config-manager --disable percona

1. Configure the failing repository to be skipped, if it is unavailable.  
Note that yum will try to contact the repo. when it runs most commands,  
so will have to try and fail each time (and thus. yum will be be much  
slower). If it is a very temporary problem though, this is often a nice  
compromise:

yum-config-manager --save --setopt=percona.skip\_if\_unavailable=true

failure: repodata/repomd.xml from percona: [Errno 256] No more mirrors to try.

Any ideas? It seems to me that the repository is broken, but maybe I am missing something…  
Thank you.

---

<div class="post-metadata">

**Author:** ![Rasto\_Stric](https://avatars.discourse-cdn.com/v4/letter/r/bc79bd/32.png) [@Rasto\_Stric](https://forums.percona.com/u/Rasto_Stric)\
**Post date:** [September 19, 2014, 2:10am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/2 "2014-09-19T02:10:08Z")

</div>

Hello Tom,

Thank you for your response.

I have tried: [LIST=1]  
[_]to use the package you had suggested: [URL][Percona – The Database Performance Experts](http://www.percona.com/downloads/percona-release/redhat/%5B/URL%5Dpercona-release-0.1-2.noarch.rpm)  
[_]to use the package: [url][http://www.percona.com/downloads/percona-release/redhat/0.1-1/percona-release-0.1-1.noarch.rpm[/url]](http://www.percona.com/downloads/percona-release/redhat/0.1-1/percona-release-0.1-1.noarch.rpm%5B/url%5D)  
[_]to use the packege: [url][http://www.percona.com/downloads/percona-release/redhat/0.1-2/percona-release-0.1-2.noarch.rpm[/url]](http://www.percona.com/downloads/percona-release/redhat/0.1-2/percona-release-0.1-2.noarch.rpm%5B/url%5D)  
[_]to use the package: [url][http://www.percona.com/downloads/percona-release/percona-release-0.0-1.x86\_64.rpm[/url]](http://www.percona.com/downloads/percona-release/percona-release-0.0-1.x86_64.rpm%5B/url%5D)  
[/LIST] I have tried all of these on: [LIST=1]  
[_]my existing Amazon linux instance  
[_]a completely new the most recent Amazon linux instance (Amazon Linux AMI 2014.03.2 (HVM) - ami-892fe1fe)  
[\*]a completely new the most recent Amazon linux instance (Amazon Linux AMI 2014.03.2 (HVM) - ami-892fe1fe) after a basic update  
[/LIST] I have tried to google, StackOverflow, AWS discussion forums.  
I have tried to apply this [url][mysql - Percona 5.6 on amazon linux ami failing - Stack Overflow](http://stackoverflow.com/questions/24882671/percona-5-6-on-amazon-linux-ami-failing%5B/url%5D).

The result is that after

```auto

yum list | grep percona 

```

or

```auto

yum install Percona-Server-client-56 Percona-Server-server-56 

```

or

```auto

yum install Percona-Server-client-56 

```

or

```auto

yum install Percona-Server-server-56 

```

I get  
Loaded plugins: priorities, update-motd, upgrade-helper  
[url][http://repo.percona.com/release/latest/RPMS/noarch/repodata/repomd.xml:[/url]](http://repo.percona.com/release/latest/RPMS/noarch/repodata/repomd.xml:%5B/url%5D) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”  
Trying other mirror.

One of the configured repositories failed (Percona-Release YUM repository - noarch),  
and yum doesn’t have enough cached data to continue. At this point the only  
safe thing yum can do is fail. There are a few ways to work “fix” this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working  
upstream. This is most often useful if you are using a newer  
distribution release than is supported by the repository (and the  
packages for the previous distribution release still work).

3. Disable the repository, so yum won’t use it by default. Yum will then  
just ignore the repository until you permanently enable it again or use  
–enablerepo for temporary usage:

yum-config-manager --disable percona-release-noarch

1. Configure the failing repository to be skipped, if it is unavailable.  
Note that yum will try to contact the repo. when it runs most commands,  
so will have to try and fail each time (and thus. yum will be be much  
slower). If it is a very temporary problem though, this is often a nice  
compromise:

yum-config-manager --save --setopt=percona-release-noarch.skip\_if\_unavailable=true

failure: repodata/repomd.xml from percona-release-noarch: [Errno 256] No more mirrors to try.

The only different message is in a case of when I get  
Loaded plugins: priorities, update-motd, upgrade-helper  
percona-release-0.1-1.noarch.rpm | 6.4 kB 00:00  
Examining /var/tmp/yum-root-eLpgFc/percona-release-0.1-1.noarch.rpm: percona-release-0.1-1.noarch  
Marking /var/tmp/yum-root-eLpgFc/percona-release-0.1-1.noarch.rpm to be installed  
Resolving Dependencies  
 → Running transaction check  
—\> Package percona-release.noarch 0:0.1-1 will be installed  
 → Processing Dependency: /usr/bin/gpg for package: percona-release-0.1-1.noarch  
 → Processing Dependency: /usr/bin/gpg for package: percona-release-0.1-1.noarch  
 → Finished Dependency Resolution  
Error: Package: percona-release-0.1-1.noarch (/percona-release-0.1-1.noarch)  
Requires: /usr/bin/gpg  
You could try using --skip-broken to work around the problem  
You could try running: rpm -Va --nofiles --nodigest

This is what I think: [LIST=1]  
[_]The error mesage (the first one) is about being unavailable (non existent) and it is true - when I put the address to a browser I get 404. Why does yum get to this link? Is it in your rpm?  
[_]Amazon linux instances have some preconfigured repositories including mysql packeges. Doesn’t it somehow conflict with the Percona package? Could be the 1 be a result of the conflict?  
[/LIST] It is hard to believe that I am the first / the only one experiencing this.  
Could you please have a look at it once more? I would really like to give the Percona server a try because it has a very good reputation but I somehow cannot get to it…  
Thank you

---

<div class="post-metadata">

**Author:** ![ceejayoz](https://avatars.discourse-cdn.com/v4/letter/c/e274bd/32.png) [@ceejayoz](https://forums.percona.com/u/ceejayoz)\
**Post date:** [September 19, 2014, 8:50am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/3 "2014-09-19T08:50:01Z")

</div>

We are also experiencing this on our Amazon Linux instances.

---

<div class="post-metadata">

**Author:** ![ghazel](https://avatars.discourse-cdn.com/v4/letter/g/ad7895/32.png) [@ghazel](https://forums.percona.com/u/ghazel)\
**Post date:** [September 22, 2014, 6:09am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/4 "2014-09-22T06:09:00Z")

</div>

Same here.

---

<div class="post-metadata">

**Author:** ![sliveroz](https://avatars.discourse-cdn.com/v4/letter/s/96bed5/32.png) [@sliveroz](https://forums.percona.com/u/sliveroz)\
**Post date:** [September 23, 2014, 12:47am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/5 "2014-09-23T00:47:57Z")

</div>

Hi I tried to execute the command above but all my repos are now giving errors…I have Percona Server 5.5 on a Amazon Linux AMI, and sudo yum update is failing so I had to disable the repos. Some packages were marked for update in the old Percona repos.

This is my sudo yum repolist:  
[url][http://repo.percona.com/release/latest/RPMS/noarch/repodata/repomd.xml:[/url]](http://repo.percona.com/release/latest/RPMS/noarch/repodata/repomd.xml:%5B/url%5D) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”  
Trying other mirror.  
[url][http://repo.percona.com/release/latest/RPMS/x86\_64/repodata/repomd.xml:[/url]](http://repo.percona.com/release/latest/RPMS/x86_64/repodata/repomd.xml:%5B/url%5D) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”  
Trying other mirror.  
I’m confused on next steps, thanks heaps

---

<div class="post-metadata">

**Author:** ![dannyg](https://avatars.discourse-cdn.com/v4/letter/d/9fc29f/32.png) [@dannyg](https://forums.percona.com/u/dannyg)\
**Post date:** [September 23, 2014, 7:07am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/6 "2014-09-23T07:07:32Z")

</div>

Hitting this problem on Amazon as well.

Before i tried the suggested solution i got:

[url][http://repo.percona.com/centos/latest/os/x86\_64/repodata/repomd.xml:[/url]](http://repo.percona.com/centos/latest/os/x86_64/repodata/repomd.xml:%5B/url%5D) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”

Now i did yum install [url][http://www.percona.com/redir/downloads/percona-release/redhat/0.1-3/percona-release-0.1-3.noarch.rpm[/url]](http://www.percona.com/redir/downloads/percona-release/redhat/0.1-3/percona-release-0.1-3.noarch.rpm%5B/url%5D)

and i am getting:

[url][http://repo.percona.com/release/latest/RPMS/noarch/repodata/repomd.xml:[/url]](http://repo.percona.com/release/latest/RPMS/noarch/repodata/repomd.xml:%5B/url%5D) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”  
Trying other mirror.

One of the configured repositories failed (Percona-Release YUM repository - noarch),  
and yum doesn’t have enough cached data to continue. At this point the only  
safe thing yum can do is fail. There are a few ways to work “fix” this:

1. Contact the upstream for the repository and get them to fix the problem.

2. Reconfigure the baseurl/etc. for the repository, to point to a working  
upstream. This is most often useful if you are using a newer  
distribution release than is supported by the repository (and the  
packages for the previous distribution release still work).

3. Disable the repository, so yum won’t use it by default. Yum will then  
just ignore the repository until you permanently enable it again or use  
–enablerepo for temporary usage:

yum-config-manager --disable percona-release-noarch

1. Configure the failing repository to be skipped, if it is unavailable.  
Note that yum will try to contact the repo. when it runs most commands,  
so will have to try and fail each time (and thus. yum will be be much  
slower). If it is a very temporary problem though, this is often a nice  
compromise:

yum-config-manager --save --setopt=percona-release-noarch.skip\_if\_unavailable=true

failure: repodata/repomd.xml from percona-release-noarch: [Errno 256] No more mirrors to try.

---

<div class="post-metadata">

**Author:** ![Alexey\_Bychko](https://avatars.discourse-cdn.com/v4/letter/a/bbe5ce/32.png) [@Alexey\_Bychko](https://forums.percona.com/u/Alexey_Bychko)\
**Post date:** [September 24, 2014, 1:52am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/7 "2014-09-24T01:52:09Z")

</div>

hello, my name is Alexey, I’m a build lead at Percona. I’m not able to reproduce the problem on my VM, so perhaps it’s something AMI-specific.

could you please provide the following:

- AMI id
- OS & version
- are there some additional files related to Percona repo in /etc/yum.repos.d?

---

<div class="post-metadata">

**Author:** ![Alexey\_Bychko](https://avatars.discourse-cdn.com/v4/letter/a/bbe5ce/32.png) [@Alexey\_Bychko](https://forums.percona.com/u/Alexey_Bychko)\
**Post date:** [September 24, 2014, 3:01am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/8 "2014-09-24T03:01:39Z")

</div>

ok, I was wrong. just tested the same setup with AMI ami-892fe1fe, and the problem is confirmed.

the root cause is AMI image (and Amazon) itself. it doesn’t use redhat version numbering like 5,6,7. it uses dates for releases like 2014.09. it doesn’t use official Centos and RedHat repositories and uses internal amazon repositories with different structure and logic.  
failure from above is caused by “latest” symlink in URL which points to latest Amazon release. we can’t set such symlink pointed exclusively to Percona Centos 6 repository.

I see 2 options there to fix that:

- do not allow AMI to define $releasever as “latest” and set it manually in percona-release.repo. you need to replace $releasever with exact Centos version in percona-release.repo. example command to replace on Centos 6 based AMIs: sed -i ‘s/$releasever/6/g’ /etc/yum.repos.d/percona-release.repo.
- do not use Amazon AMIs in such case, because they are not exactly the same OS, it’s some kind of OS fork made by Amazon and adjusted exclusively for Amazon services, software and infrastructure. use Centos AMIs.

I hope it help

---

<div class="post-metadata">

**Author:** ![sliveroz](https://avatars.discourse-cdn.com/v4/letter/s/96bed5/32.png) [@sliveroz](https://forums.percona.com/u/sliveroz)\
**Post date:** [September 24, 2014, 4:24am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/9 "2014-09-24T04:24:46Z")

</div>

Hi Alexey

Thank you for your reply.

I’ll give a try with option 1, I’ll have to read about it a little bit though as it’s out of my (limited) yum knowledge.

At the moment I disabled the Percona repos so I’m not getting updates for my Percona Server 5.5 install.

Amazon makes it easy to use the standard MySQL installation with Amazon Linux, but I’m keen on try to keep using Percona as it performs better.

Thanks

---

<div class="post-metadata">

**Author:** ![sliveroz](https://avatars.discourse-cdn.com/v4/letter/s/96bed5/32.png) [@sliveroz](https://forums.percona.com/u/sliveroz)\
**Post date:** [September 24, 2014, 6:24pm UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/10 "2014-09-24T18:24:40Z")

</div>

Hi Alexey

I’ve managed to successfully update my installation following your instruction doing:

sed -i ‘s/$releasever/5/g’ /etc/yum.repos.d/percona-release.repo

yum clean all

yum update

All the packages were updated correctly and everything seems to work ok thanks.

However I’m still getting this error:

2 packages excluded due to repository priority protections

and if I do

yum update -d3

I get those packages:

→ jemalloc-3.3.1-1.el5.x86\_64 from percona-release-x86\_64 excluded (priority)  
 → jemalloc-devel-3.3.1-1.el5.x86\_64 from percona-release-x86\_64 excluded (priority)

Is this something to worry about? Is it possible to fix it?

Thanks and regards

---

<div class="post-metadata">

**Author:** ![Tomislav\_Plavcic](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/tomislav_plavcic/32/9717_2.png) [@Tomislav\_Plavcic](https://forums.percona.com/u/Tomislav_Plavcic)\
**Post date:** [September 25, 2014, 5:13pm UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/11 "2014-09-25T17:13:51Z")

</div>

Hi sliveroz,

regarding package exclusions that seems to be just a notification since you’re using yum-plugin-priorities and it means that you have the same package in some other repository which has higher priority so I wouldn’t worry about it.  
Jemalloc in our repo is not some special modified version so it should work from other repositories as well.

Kind regards,

---

<div class="post-metadata">

**Author:** ![sliveroz](https://avatars.discourse-cdn.com/v4/letter/s/96bed5/32.png) [@sliveroz](https://forums.percona.com/u/sliveroz)\
**Post date:** [September 28, 2014, 6:30pm UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/12 "2014-09-28T18:30:22Z")

</div>

Hi, thanks for your reply, great to hear.

---

<div class="post-metadata">

**Author:** ![njt1982](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/njt1982/32/1045_2.png) [@njt1982](https://forums.percona.com/u/njt1982)\
**Post date:** [October 30, 2014, 6:11am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/13 "2014-10-30T06:11:42Z")

</div>

I think some of the confusion may be around the website not being updates…

[url][http://www.percona.com/downloads/percona-release/[/url]](http://www.percona.com/downloads/percona-release/%5B/url%5D) - lists 0.0.1  
[url][http://www.percona.com/downloads/percona-release/redhat/latest/[/url]](http://www.percona.com/downloads/percona-release/redhat/latest/%5B/url%5D) - lists 0.1.3

---

<div class="post-metadata">

**Author:** ![njt1982](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/njt1982/32/1045_2.png) [@njt1982](https://forums.percona.com/u/njt1982)\
**Post date:** [October 30, 2014, 6:45am UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/14 "2014-10-30T06:45:38Z")

</div>

Still not right…  
[http://repo.percona.com/release/6.6/RPMS/noarch/repodata/repomd.xml:](http://repo.percona.com/release/6.6/RPMS/noarch/repodata/repomd.xml:) [Errno 14] PYCURL ERROR 22 - “The requested URL returned error: 404 Not Found”

The release RPM installed this, (truncated)

########################################

# Percona releases and sources, stable

########################################  
[percona-release-$basearch]  
name = Percona-Release YUM repository - $basearch  
baseurl = [http://repo.percona.com/release/$releasever/RPMS/$basearch](http://repo.percona.com/release/$releasever/RPMS/$basearch)  
enabled = 1  
gpgcheck = 1  
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-Percona

[percona-release-noarch]  
name = Percona-Release YUM repository - noarch  
baseurl = [http://repo.percona.com/release/$releasever/RPMS/noarch](http://repo.percona.com/release/$releasever/RPMS/noarch)  
enabled = 1  
gpgcheck = 1  
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-Percona

[percona-release-source]  
name = Percona-Release YUM repository - Source packages  
baseurl = [http://repo.percona.com/release/$releasever/SRPMS](http://repo.percona.com/release/$releasever/SRPMS)  
enabled = 0  
gpgcheck = 1  
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-Percona

$releasever is “6.6”, not “6”…

---

<div class="post-metadata">

**Author:** ![alekseykorzun](https://avatars.discourse-cdn.com/v4/letter/a/aeb1de/32.png) [@alekseykorzun](https://forums.percona.com/u/alekseykorzun)\
**Post date:** [November 18, 2014, 1:22pm UTC](https://forums.percona.com/t/yum-repository-seems-to-be-broken/3751/15 "2014-11-18T13:22:32Z")

</div>

It looks like Percona does not support 6.6 (Santiago) version of CentOS.
