# xtrabackup too slow, The copying transaction log migh be overtaken already by the target

**URL:** <https://forums.percona.com/t/xtrabackup-too-slow-the-copying-transaction-log-migh-be-overtaken-already-by-the-target/2291>\
**Category:** Percona XtraBackup\
**Created:** [September 13, 2012, 4:30am UTC](https://forums.percona.com/t/xtrabackup-too-slow-the-copying-transaction-log-migh-be-overtaken-already-by-the-target/2291 "2012-09-13T04:30:32Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![achapela](https://avatars.discourse-cdn.com/v4/letter/a/35a633/32.png) [@achapela](https://forums.percona.com/u/achapela)\
**Post date:** [September 13, 2012, 4:30am UTC](https://forums.percona.com/t/xtrabackup-too-slow-the-copying-transaction-log-migh-be-overtaken-already-by-the-target/2291/1 "2012-09-13T04:30:32Z")

</div>

After changing the transactions in my app, my innodb binlog is increasing fast than before change.

Now I have getting error in my backups and it never ends. Before backup take about 3,5 hours or so and now after 7 hours it has taken about 25% of total backup size.

I have tried with version 1.6.4 and 2.0.2 and the error is:  
Version 1.6.4:

> > ###Warning###: The copying transaction log migh be overtaken already by the target.  
> > : Waiting log block no 80669053, but the bumber is already 84765037.  
> > : If the number equals 80669053 + n \* 2047992, it should be overtaken already

Version 2.0.2:  
xtrabackup: error: log block numbers mismatch:  
xtrabackup: error: expected log block no. 410098410, but got no. 412146402 from the log file.  
xtrabackup: error: it looks like InnoDB log has wrapped around before xtrabackup could process all records due to either log copying being too slow, or log files being too small.  
xtrabackup: Error: xtrabackup\_copy\_logfile() failed.

Why is it running so slow ?

---

<div class="post-metadata">

**Author:** ![achapela](https://avatars.discourse-cdn.com/v4/letter/a/35a633/32.png) [@achapela](https://forums.percona.com/u/achapela)\
**Post date:** [September 13, 2012, 4:56am UTC](https://forums.percona.com/t/xtrabackup-too-slow-the-copying-transaction-log-migh-be-overtaken-already-by-the-target/2291/2 "2012-09-13T04:56:46Z")

</div>

I need to explain that I have already increased the size of binlog from 100MB to 500MB and from 500MB to 1GB. The result is always the same

---

<div class="post-metadata">

**Author:** ![achapela](https://avatars.discourse-cdn.com/v4/letter/a/35a633/32.png) [@achapela](https://forums.percona.com/u/achapela)\
**Post date:** [September 25, 2012, 7:18am UTC](https://forums.percona.com/t/xtrabackup-too-slow-the-copying-transaction-log-migh-be-overtaken-already-by-the-target/2291/3 "2012-09-25T07:18:33Z")

</div>

OK, this was caused by a problem with io troughput
